Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Emoncms.org: dashboard list not working

When going to Emoncms - user login none of my dashboards shows up. It just says loading. It was working last time i tried (maybe a month or two since). I have tried multiple computers and browsers.
Have the version running on emoncms.org recently been updated with a new version containing a bug that causes this?

I have the same problem. I made a new account and registration and everything works. In the old account, I only see fields and loading data.

Sorry about this, I can see the issue, working on it now.

This is now fixed, we upgraded one of the libraries this week (jquery) and it broke a couple of lines in the dashboard code, all working now.

Fix is also available in the dashboard master branch if you are seeing a similar issue locally fix jquery 3.6.0 support · emoncms/[email protected] · GitHub

I still have a problem. User ID 35131

Hello @Miroslav_Polacek it should be resolved for you now. sorry about that!

Thank you very much, now it is OK.

Hi @TrystanLea
Thanks for fixing this! It is working for me now.

1 Like

Hello, I also have a problem, ID number 34998, I also have a problem in the mobile application Emoncms on iOS

Hi,
I am self hosted and recently upgraded to “Components: Emoncms Core v10.7.7 | App v2.1.6 | Dashboard v2.0.7 | Device v2.0.5 | Graph v2.0.9” - and like the updated admin pages. I did just do a git pull and picked up the changes for jquery-3.6.0, however I am still having a couple of issues. I do not see a menu option for dashboards or apps.
I have an open dashboard, that is now showing a hamburger menu and exit icon on top of the dashboard which look bizarre and don’t add anything.

Not sure if this is something that I have caused in having my location being custom (/var/www/htdocs/emoncms) or some other cause. Any help would be much appreciated.

Thanks - Bryan.


image

I have the same problem as issue #1721. User ID 28071. Can anybody help me please?

Hello @Tuecki @martin_prielozny should be fixed now, let me know if you see any issues?

@montgomeryb sorry I missed your post there. Have you managed to fix this since? Can you update all components again? You should have dashboard v2.1.4…

Thank you work it.

1 Like

the program worked for a while, now I can’t enter it
feed, I deleted the old account, created a new ID 42472, it is still not possible to enter the feed

Thanks @TrystanLea - no problem. I went in to the different modules and did a git pull origin master and now have much newer components, and back to a normal looking dashboard …

Components: Emoncms Core v10.8.1 | App v2.1.6 | Dashboard v2.1.4 | Device v2.1.2 | Graph v2.1.1

On another note, I did realise that the admin serial term, and the service starting / stopping is expecting the script to be run as root. As I run it as the www user, those commands don’t work. I’m thinking that when I get time, I can convert those to sudo commands and add permissions to the sudoers file. We’ll see if I get time :slightly_smiling_face:

@martin_prielozny I dont quite understand, what could you not enter for the feed?

@montgomeryb I think they should be sudo commands e.g: emoncms/service-action.sh at master · emoncms/emoncms · GitHub

already working

1 Like

Hello, I have problem with show web side without login. When I am login ewerithing wokrs but when I log off and I put adrres in web viewer. Web side is without values…


… ID 42096. I have set up to publish dashboard… Where is problem?
https://emoncms.org/dashboard/view?id=60933