Still no changes…

We are at the end now and have absolutely no idea what to do.

Changed modules again
Tried 4 different power cables
Changed batteries…

Attention Update:
The Problem has been shifted:

All modules from 16 → 11 (5 modules are now dismantled from the pack) - number 11 was the one that produced that strange voltage I reported before.

Now as you can see in the screenshot, the “wrong” measurement shifted to cell number “6”.

So I´m more and more convinced that we´re talking about a software issue and not a hardware problem. Or maybe a communication problem. I don´t know…

And another update to it:

If we start to unattach the modules from top number downwards the problem with the wrong displayed voltage is shifting WITH the modules down until we reach number “0” (1st module/cell).

This is for sure a software issue / bug.


When i first built my v4.4 modules i accidentally left off D1 (the voltage reference) AZ432ANTR-E1.

They exhibited the exact same erratic symptoms.

When i say I left off … it was really JLCPCB didn’t have them (nor attiny) - I added the tiny but forgot the voltage ref.

Also make sure you reload your browser - i have on occasions had trouble doing updates to the controller/modules until i reloaded my browser - no error message … just doesn’t work - i haven’t debugged why but believe assume stale cookie.


If it is, it’s the first time it’s been reported in over 5 years! Either way, I’m happy to fix and bugs when found.

I’d be surprised if it were a code issue though. The modules are electrically isolated from each other. They are in effect autonomous, they have their own CPU etc.

All the controller does is ask each module for it’s voltage readings.

In the 2 years I have had this system running, there have been two times that one of the modules has started to go bad, I replaced the D1 and so far. Carlos, from what you describe, it sounds to me like a hardware problem, some component of some modules or of the controller has degraded, it is not frequent, but it can happen
I also recommend that you carefully review the communications (even reviewing the RX TX soldering in each and every one of the modules) and of course the quality of the communication cables

the wait is over , on friday i will receive 57 attiny 1624 purchased directly from Microchip Tecnology . I am looking forward to receive them and test my prototype of 16 modules


Hello, i wanted on this: to solder on my variant 4.5 board directly mounted on cells.
bms v45a
AZ432ANTR have an alternative, i have many LM385-1.2 : LM385-1.2 pdf, LM385-1.2 Description, LM385-1.2 Datasheet, LM385-1.2 view ::: ALLDATASHEET :::

do you want to flash the 10k firmware?

Yes, I want to try the higher speeds
In my previous system for 4.4 modules I can only put speed of 5K