Shot I will give it a go

@stuart i tried hysteresis branch on the controller, should i not expect some more settings in webinterface ?

I just do an upload again in VS Code after i switched branch but i can’t see anything new.

Did you “upload file system image”?

Umm not sure but since I am not sure then I am sure I didn’t, how is that done ? I just clicked “Upload” is there another option from VS code?

Update: found it and it works. thx

@stuart i ran out of the power resistors Ever Ohms Tech | Ever Ohms Tech CR2512F2R20E04S | Chip Resistor - Surface Mount - LCSC.COM so i need to order new ones but can’t wait for LCSC so i found these CRCW25122R20FKEG Vishay / Dale | Mouser Denmark , i see no reason why they shouldn’t work, same specs, do you see any issues ?

i am making v.4 boards.

See this… Platform IO V5 "Upload file system image" option moved - #13 by allnewtothis

The resistor looks okay. For V4 boards the key points are:

  • 2.2 ohms
  • 1 Watt
  • 2512 SMD size
1 Like

Sometimes an error pops up “PCF8574 is NOT connected/fitted, relay control not possible!” after loading. If you restart several times, the power supply sometimes disappears. What could it be?

I suspect that’s a bit of bad soldering - check the connections around the PCF chip.

@stuart not sure if this question has been asked before, can different version modules be used together for example 4.21 with 4 ? i presume yes since the communication is the same but just to be sure i ask, not that i need it now but you never know if one board goes south and i only have one type of replacement.

Yes all versions can be mixed and matched.

1 Like

I finally had time to finish my DIYBMS cell units.

I liked them to have heatsink.
With no good way for me to mount them, I used the simple and usually safe for electronics “hot glue”.

I might regret this on later phase, for now the cell PCB are horizontal, and the heatsink is additional aid.

The heatsink doesn’t make contact with any of the other components.

After connecting one controller board and 2 cell modules nothing happens at the web interface.

“The controller is having difficulties communicating with the cell modules.”

The ones not connected to the controller blink twice blue every 5 seconds.

The 2 that are connected blink after 3 seconds, first module 1, then 2, then 1 then 2 and 3 seconds pause.

I made errors during my first order at JLCPCB, and ended up soldering the control module myself.

Not so many parts and it all seems to be soldered OK.
I do not know how I can test!
(Except programming and turn it on :slight_smile:
2 boards soldered, 3 not yet.

It all seems fine, except that it isn’t working.

Can you please point me in the right direction for getting this problem solved?

@stuart i am testing my diyBMS with a bench power supply instead of a battery so i do following :

  1. Set the power supply to 3.33V and let it use 1A. (i measure with FLUKE meater that this is indeed the voltage)
  2. I set the bypass to 3.0V

Now the module goes into bypass and is red. For some time this is working and it pulls around 700mA i can see. The voltage i still keep at 3.33V but the voltage reading in diyBMS fluctuates from 3.33V to 3.23V, is that acceptable ? Seems to much considering the voltage reading i get from FLUKE while the module is in bypass is 3.33V - 3.29V. Also the module blinks red some time really fast, i am not sure if that’s normal and also how long would it try to bybass ? In my simulation the voltage would never go down since it’s a power supply. Is diybms stopping maybe within a timeframe or ?

If there’s an update to the code, is there some way of pushing the updates to all the modules from the controller? I’ve just created 48 modules to monitor my 48 LiFePO4 cells and having to update these individually and manually if and when an update becomes available would be somewhat laborious. BTW, thanks Stu for an amazing project! I’ll be sure to upload photos of my install when it’s all done!


The flashing red LED is normal - its the PWM doing its thing to ensure the module doesn’t get too hot. The current should also change over time when the red LED is flashing (it reduces the current to lower heat).

The module is sensitive to the resistance of the wires connecting to the battery/power source - are you measuring the voltage on the module itself?

The module won’t have FLUKE accuracy - but I think that looks good enough for me!

I soldered my third controller board,
Still the same error, with a fresh controler board. it doesn’t see any cell module :frowning:

I erased the Wemos D1pro and reinstalled the software.
I do get a warning:
‘SPIFFS’ is deprecated (declared at C:\Users\Frank.platformio\packages\framework-arduinoespressif8266\cores\esp8266/FS.h:269): SPIFFS has been deprecated. Please consider moving to LittleFS or other filesystems. [-Wdeprecated-declarations]

and an error:
cannot open source file “stddef.h” (dependency of “ESPAsyncWebServer.h”)

No idea if they are important, or how to fix…

I’ve added now 3 modules…
all seems to go nicely, green lights “walking” from first to second to third cell, twice, then 3 seconds pause and it walks again.

removing one the the connection cables does provide expected behaviour, blue flashing.
reconnect, its green again. (by standard I disconnect the power for the Wemos when playing with RX and TX cables)

Any ideas on how to troubleshoot this??

The SPIFF warning can be ignored - You shouldn’t get the stddef.h error though. Perhaps try a “CLEAN” on the VSCODE before build/upload. If the controller is working and you can see the webpage - no need to reflash it won’t fix anything.

Simple hardware debug procedure…

  1. With no modules connected to the controller, you should get the web page and lots of errors.
  2. Build a temporary loop cable to connect the tx and rx together on the controller - you should get lots of “ignored” errors. This proves the controller is working and wired up.
  3. Connect a module one at a time - they should just appear on the web interface one by one.

If any of the modules don’t show up, you have a soldering and/or programming issue with the module. When you upload don’t forget to use the “burn fuses” option on the ATTINY.

just flashed new wemos, not 16mb but 4MB clone.
again, wemos works fine, all seem to be OK, except it doesn’t see any cell modules.

controller part is just the led, resistors 470R, 3*4K7 and 220R, ooptocoupler and the PCF8574AT?? (and the wemos)

Do I have a wrong PCF8574AT???

I just got mine up and running and realised that the wires from TX/RX between the controller and all modules need to be crossed over ie. not straight. My pre-crimped cables are all straight through so I’ll need to redo all 50 of them

not crossed over will prevent the signals from the modules to reach the controller ??
I havent twisted them yet,
I use Dupont wires as they are more convenient for me.
twisting them is easy …

I’ll try and let you know if this helps.