Community
OpenEnergyMonitor

Community

Can't get emonTx to enter RF config mode

uart
serial
hardware
emontx
Tags: #<Tag:0x00007f1be0326290> #<Tag:0x00007f1be0326128> #<Tag:0x00007f1be0325fe8> #<Tag:0x00007f1be0325ea8>

(otis harrison) #8

emonTx V3.4 Discrete Sampling V2.60
OpenEnergyMonitor.org

No EEPROM config
RFM69CW Node: 8 Freq: 433Mhz Group: 210

POST.....wait 10s
'+++' then [Enter] for RF config mode
CT 1 Cal 90.90
CT 2 Cal 90.90
CT 3 Cal 90.90
CT 4 Cal 16.67
RMS Voltage on AC-AC  is: ~251V
AC-AC detected - Real Power measure enabled
assuming pwr from AC-AC (jumper closed)
USA mode active
Vcal: 130.00
Phase Shift: 1.70
NO CT's detected
No temperature sensor
CT1 CT2 CT3 CT4 VRMS/BATT PULSE 
ct1:78,ct2:0,ct3:0,ct4:0,vrms:11998,pulse:0
ct1:8,ct2:0,ct3:0,ct4:0,vrms:11998,pulse:0
ct1:10,ct2:0,ct3:0,ct4:0,vrms:12031,pulse:0

(Glyn Hudson) #9

All looks good, please report on the USB to UART test. I’m suspecting faulty cable


(otis harrison) #10

Tried another usb to micro cable and still not sending the +++. is there a way to check the serial to usb programmer board?


(Paul) #11

If you link the RX and TX together on the serial programmer instead of connecting it to a device, you should be see everything you type into the arduino IDE’s serial console, echoed back. It’s a simple test that simply loops the transmitted serial output back down the received line. You can use a short piece of wire or a metal paper clip.


(Robin Emley) #12

How about trying a different sketch, such as blink.ino? If that works, the upload side of the cable/hardware must be OK. The original emonTx V3.4 Discrete Sampling V2.60 code can then be installed again.


(Glyn Hudson) #13

Is anyone else running V2.6? Is serial config working ok for you? I can replicate the issue, we have been using it in the factory for some time now to set node ID.


(otis harrison) #14

I connected the rx to tx on the programmer board and it will repeat what I send


(Paul) #15

Is it a programmer supplied by the OEM shop?

Providing the pinout is as expected, this would suggest there is a problem with the emontx or the firmware installed. Next step would probably be to try and reinstall the firmware.

Are you waiting >10s <20s? from when the serial prints these messages

POST.....wait 10s
'+++' then [Enter] for RF config mode

Once those messages print the emonTx seems to sleep for 10s before there is a 10s window to reply. Try waiting 15secs from when the message appears to [enter] the +++ to hopefully put you in the centre of the 10s window.


(otis harrison) #16

yep I got it from the shop. I am wait 10s after the mode line


(Paul) #17

Try 15secs, 10s is cutting it fine since the code sleeps for 10s and does other stuff before beginning to set up to listen, if all 3 +'s are not seen it won’t work either.

Are you using the Arduino IDE? Try setting the line ending to “Both NL & CR” if it isn’t already


(Glyn Hudson) #18

Any update on this? Did you manage to resolve the issue? I’ve just tested again and can confirm V2.6 firmware serial config works fine with the shop USB to UART adapters. Tested with platfrmIO serial monitor and minicom (@115200 baud).


(otis harrison) #19

It is working. It was the board. One of the pin wasn’t connected all the way. Thanks man. Have another question when USA 1 is on that means the Vrms changes to 130?


(Glyn Hudson) #20

A post was split to a new topic: EmonTx V3 USA apparent power


(Glyn Hudson) #21

Great! Glad you got to the bottom of the issue.

When USA mode is enabled vrms calibration = 130. This is the calibration for the AC-AC USA plug voltage sensor adapter sold via the shop.

I’ve just noticed a bug when using emonTx in apparent power mode with USA mode enabled. I’ve pushed a fix for this and started a new thread. See above.


(Bill Thomson) #22

Glyn,

Clicking on the link in your post yields a 404 error. (page not found)

This is the link text: https://github.com/emoncms/AndroidApp/invitations


(Glyn Hudson) #23

Woops, that was the wrong link! I’ve removed it. Too much multitasking!


(Claudio A. Heckler) #24

Let me add a comment on this thread, in case others stumble upon this:

I was just configuring the node numbers on three emonTx today and I was using the “Arduino IDE’s Serial Monitor” as my serial terminal SW (on Windows).

This particular terminal allows you to set what type of carriage return to send when you hit ENTER, the options are “No line ending”, “Newline”, “Carriage return” and “Both NL and CR”.

Don’t know if this is a quirk in Windows, but I had to set it to “Both NL and CR” in order to be able to access the config menu with +++ [ENTER]; any other setting would not register the command correctly.


(Bill Thomson) #25

I thought I’d seen something about this.
A search showed PB66 did indeed mention it in this thread.


(Robert Wall) #26

And that is printed on-screen by the emonTx. From the source code:

  Serial.println("POST.....wait 10s");
  Serial.println("'+++' then [Enter] for RF config mode");
  Serial.println("(Arduino IDE Serial Monitor: make sure 'Both NL & CR' is selected)");

NL & CR are required for Linux as well, it’s not just Windows.


(Bill Thomson) #27

That’s the other place I’d seen it. Couldn’t for the life of me remember where it was.
I’ve slept since then. :grin: