Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Can't connect to Ethernet or Wifi

My internet provider has suffered an outage today (now back online). Now I find the EmonPi is not connected to Wifi or Ethernet. I tried restarting but no luck. I use the temperature sensors connected to the EmonPi in another RPi that serves as my thermostats, so currently have no automatic heating control. Any ideas on how to get reconnected? Is there a way to initialize the EmonPi similar to a first startup?

Thanks

What information does your router give you?

That means you’ve tried wired Ethernet as well as Wi-Fi?

The router might have given it a new IP Address, is your Wi-Fi password still the same?

The place to start is your router. Does the emonPi show in the list of connected devices in your router?Ethernet is the “safest”, because it should not need a password to connect.

The only reference I’ve got in my handy list is
Force the Emonpi to AP-mode - #4 by borpin which says:
To force an EmonPi back into AP mode, go into ‘WiFi’ from settings and deselect the currently selected WLAN. Click on save and then refresh. You will still have access to the emoncms instance. Navigate to the admin menu and click reboot. The EmonPi will now come up in AP mode (as no network is configured).
But if you can’t communicate with the emonPi in the first place, that’s not open to you.

What does the EmonPi LCD say?

Use a tool like ‘Fing’ on your phone. When connected to the same Wi-Fi network, it will tell you if the EmonPi is connected and the IP address (if it isn’t in the LCD screen - you need to press the button to cycle the menu).

Always good to have a fall back. I have the ‘traditional’ thermostats in parallel but set low, so if the clever one fails, I just turn the old one back up.

Just because the outgoing part of your network is not working, the inside bit should still have been OK unless you did something to the router to try and ‘fix’ the outage.

This is also why for me, the ISP Router just handles the internet then hands off internal routing to a separate Wi-Fi router (ISP Router Wi-Fi is off). I can change ISP very easily!

It says WIFI NOT CONNECTED
Also says ETHERNET NOT CONNECT if I connect a cable.

I do have thermostats connected in parallel.

I made no changes to the router.

When I do arp-a it reads: ? (192.168.1.11) at (incomplete) on en0 ifscope [ethernet]

I have connected a keyboard and HDMI to the RPi, but when I do ifconfig I don’t see an IP address. Can I force AP mode from the command line?

You probably have, but I’ll ask anyway, have you restarted the router?

Other devices are OK?

What do you get?

All devices OK, I did restart the router.

I’ve connected a dinky dink keyboard and can’t cut and paste to my PC.

But essentially I get:
lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 nwtmsk 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
(plus some other stuff like rx packets, etc.

wlan0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether b8:27:eb:eb:1b:ac txqueuelen 1000 (ethernet)
(plus some other stuff like rx packets, etc.

Odd.

yes

sudo wifiAP start

Although this script is quite old now, so no certainty it will work.

So how will that work as I only have access to the command line? Or in other words, what can I expect to happen?

One thing: currently my router is set to assign the IP address to the RPi, should I disable that if I force AP mode?

to connect to the AP. However, the slightly worrying thing is it didn’t work with a cable and that should just work.

Using a USB keyboard and connecting the HDMI port I did ‘sudo wifuAP start’ and that part worked. The emonpi then displayed WIFI AP MODE 192.168.42.1. I followed the instructions in the connection guide but I had to reboot the emonpi to get it back on my wifi at the usual IP address. Looks like it’s all good now.

I’ve had the thing running for almost 18 months with no issues so I’m very happy with reliability

Thank you Brian and Robert for your help, did anyone ever tell you you’re the greatest? :wink:

1 Like