Cannot create Feed from MQTT input

Continuing the discussion from Publish to MQTT Issue:

I am experiencing the same ERROR: Could not save processlist. undefined disappear issue. I created a simple nodered flow that publishes gallons to emon/water/gallons. I can see the data on the Input View page:

 
and I can do a MQTT subscribe and all the data appears as expected.

But when I click on the Spanner/Wrench, create a feed and click Changed, press to save I then get this error:

A reboot seemed to fix this last time, but I’d rather grab some troubleshooting info before I reboot.

This is an emonPi with the emonSD-03May16 image.
Emoncms Version low-write 9.7.2 | 2016.07.04

EDIT: One other piece of info. When ever I go thru the above steps it partially creates a Feed but with no Values.

EDIT 2: updated above images to higher resolution.

Only last screenshot is readable, the 2 others can’t be zoomed in and for me it is impossible to read the error message for exemple.
I guess this is local install, is the SD card not near full by any chance ? Reboot often cleans out many cached files and gives some extra space but problems will arise soon enough if it is this case.

Hey Eric! I updated the above images. (I shrunk them too much trying to save OEM server space!)

Yes, local install on an emonPi and using an 8 GB SD card. The SD card isn’t full but it is getting there in the “root” area. And there are no obvious errors in any of the logs (i.e., emonhub, emoncms, syslog).

[email protected]:~ $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root       3.4G  2.6G  629M  81% /
devtmpfs        483M     0  483M   0% /dev
tmpfs           487M     0  487M   0% /dev/shm
tmpfs           487M   37M  450M   8% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           487M     0  487M   0% /sys/fs/cgroup
tmpfs            40M  6.6M   34M  17% /var/lib/openhab
tmpfs           1.0M     0  1.0M   0% /var/lib/dhcp
/dev/mmcblk0p1   60M   21M   40M  35% /boot
tmpfs            50M  5.6M   45M  12% /var/log
tmpfs           1.0M  4.0K 1020K   1% /var/lib/dhcpcd5
tmpfs            30M   40K   30M   1% /tmp
/dev/mmcblk0p3  3.8G  819M  2.8G  23% /home/pi/data
[email protected]:~ $ 

I didn’t want to reboot until I exhausted all troubleshooting opportunities for @glyn.hudson or @TrystanLea. I am fairly sure that a reboot will fix the issues but just temporarily.

Thanks for reposting, this is a known issue:

I tried to debug, but need @TrystanLea’s deep knowledge of emoncms input processing, to help me.

Discussion continued on this thread: