OpenEnergyMonitor Community

Cannot connect emonPi to wifi - frozen setup page

Is this setting up the manual way? By editing the file manually?

Mm interesting, is looks like if any of the SSID’s have special characters in them this causes the emoncms wifi module to not function correctly. I am away for next the week. I will try and debug when I get home. I’m glad you have managed to set up the wifi the manual way.

Hi, I have the same problem, just installed the latest SD image emonSD-07Nov16 on a Pi2 with Edimax
My chrome dev console output after hitting “save & connect”:

wifi:129 Uncaught TypeError: Cannot read property 'checked' of undefined
at HTMLButtonElement.<anonymous> (
at HTMLButtonElement.dispatch (
at HTMLButtonElement.r.handle (

There are wifis with “!”, “_”, “-” and “” in my scan list, the first two are very common in standard SSIDs in germany.

my wpa_supplicant.conf:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

my /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)

# Please note that this file is written to be used with dhcpcd
# For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d

auto lo
iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
iface wlan0 inet dhcp

# GSM 3G Hi_Link USB modem
allow-hotplug eth1
iface eth1 inet dhcp

If i follow Marcels steps setting wifi up edditing the wpa_supplicant manually it works.

Since your last answer was from July and this is not fixed in the November image may I suggest giving this more priority? The only wired character i see in my list is “”, but especially in cities where you might have 20+ wifis in range there will be some odd ones.


Oh dear, very sorry to hear. Thanks for providing debug info. I will try and take a look as this very soon. Is this the same issue as reported on this thread?

I have a very similar issue to this but this time it’s with a PSK that has a special character in it, it looks like the wpa_passphrase program doesn’t handle that very well.

Also, how do I get the emonPi to see / join a WiFi network on channel 13?

A post was split to a new topic: Using emonPi / emonPi WiFi on Channel 13

I’ve just replied on a new topic :+1:

1 Like