Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Cannot connect emonPi to wifi - frozen setup page

Hi all. I am trying to connect the emonPi to the wifi network.

I log in to emoncms with an ethernet connection. However, the wifi setup page seems to be frozen: I select the network, add the password, click “connect”, “refresh” (or start, restart or any of the buttons) but nothing happens.

This is not the first time this happens. Last time (different emonPi) I used SSH to access the emonPi and hardcode SSID and password. Now I am even refused access to that.

Does anybody know what I’m doing wrong? Seems such a trivial thing (and possibly is) but it stops me right there… Attached some screenshots.

Different to last time, I had to purchase the wifi dongle (Edimax 7811) separately. Could that be an additional source of complication?

Thanks a lot!!!

Sorry to hear your having trouble. Did you check the tick box to select the network you wish to connect to before hitting Connect?

It can take 5-10s to connect.

Have you got an emonPi with a RaspberryPi3 (one end-plate will be black acrylic) with onboard wifi?

Or do you have and older emonPi (two metal end-plates)? If you have an older emonPi with RasPi2 then you will need to use an external Edimax USB network adapter.

Hi Glyn, thanks for reply!

I did check the tick box, so that’s not the issue. And I waited different amounts of time, nothing happening. Still frozen and wifi not connecting.

It’s a RaspberryPi3. I guess that’s why I see the wifi networks in the first place :slight_smile:

Logging entries

Can you show me your browser dveloper console output when you hit connect? Here is an example of what I see when I hit connect. The emonPi then connect to the network in a few seconds. I am running a Pi3.

First screenshot directly after clicking “save and connect”. Is this what you mean?

Second screenshot of what could be relevant entries, as they change quite fast.

Have you got Chrome installed? Could you test and show my the console output from Chrome? Sorry, I’m not familiar with the Safari console output. I’m not convinced there errors we are seeing in the safari console are relevant.

Hi Glyn. Here’s the output from console in Chrome. The error seems to be related to the first network showing up in the scan (see screenshot in next post).

Thanks, that gives us some more info. It looks like maybe the Emoncms wifi module does not like the apostrophe in your SSID. I have tested connecting to a SSID with a space in the name, bit I have not tested with multiple spaces and an apostrophe. Do you have a wifi hotspot with a simple SSID you can test with? You could create a wifi hotspot from a smartphone to test.

Ok, thanks! Unfortunately, that one is a neighbour’s network, which I can’t change. It’s surprising that the signal is stronger than my network. I will try to physically move away further or test it out in a completely different place where I can have access with an ethernet cable.

I’m having the same problem, My set up is Emontx,Emonbase,EmonGLCD. Running EmonSD=3May16,EmonCMS=9.7.1,Emontx3_4=Rev 2.3. I’ve tried several installs of EmonSD on Pi w/no success. Here is my console output:

Ah dear, sorry to hear. Thanks for helping to debug.

Can you connect via ssh? If so it would be very useful to see the contents of etc/wpa_supplicant/wpa_supplicant.conf

$ sudo cat etc/wpa_supplicant/wpa_supplicant.conf

See troubleshooting section of the user guide for information on how to ssh. If your using Windows you will need to use putty. Username is ‘pi’ and pass ‘emonpi2016’

Checked and found “no such file/directory”

That path should have been

sudo cat /etc/wpa_supplicant/wpa_supplicant.conf

Syntax gets you everytime. Here is the print screen, thanks for the correction.

Hi, I also did what you suggested Manuel. Below the output from the terminal.

I can make the wifi work by writing the network SSID and password into the wpa_supplicant.conf file as suggested here: Raspberry Pi Documentation - Configuration

When I physically moved the emonPi, so that the network SSID with the apostrophe wasn’t the first network, it still did not work.

However, setting up the emonPi in a different place with no ‘apostrophe’-networks, it worked out well :slight_smile:

Hi Paul,Glyn and Marc

I replicated what Marc suggested and now I can have wifi access. Why was I not able to before? I thought that the EmonCMS/EmonSD image made it possible.

Thanks Marc