Can’t get the Serial Config Tool to work with computer equipped with USB-C

I have a working set up - even sending to the server fine.

However, I need to change the settings for the sensor inputs but can’t find a way (after a day of struggling) to get the changes made. I have tried to use the tool under Admin/Serial Config but that doesn’t seem to change anything. When I click Save Changes, nothing seems to happen, and it does not appear to have made the change I need (20A—>100A on input 6). The readings are still wrong for that input.

I then tried to use the web tool in Chrome, having plugged in the emonTx4 to my Mac. All I get is ‘ wants to connect to a serial port - No compatible devices found’. I tried different cables, different orientations of the USB-C plugs to no avail. I suspect I am missing a driver or something like that …. I also tried on a Windows 11 PC - same issue.

This seems such a trivial thing to need to be done - but I am totally stuck.

Any suggestions?

Thanks, Jeff

Hurray - I have solved by problem.

I had installed the latest driver for Mac from Prolific, and it seemed to have installed OK, but I couldn’t see any sign of it I still can’t.

I had tried an Apple cable and an Anker cable, switching the plugs through 180 degrees in all combinations - no luck. Then I tried a cable from GoPro - it was a USB-A to USB-C. So I added an adapter to make it USB-C to USB-C and bingo - the Mac reported a new device.

The connection from the Serial Config Tool then connected first to a bridge and then to the emonTx4.

I’ve changed the input sensor types now - all is good.

Phew ….

So you suspect both USB-C to USB-C cables you had were incompatible with either (presumably - you didn’t say) your emonTx4 and any computer with a USB-C connector, but the USB-C to USB-A adapter plus the USB-A to USB-C cable solved the problem.

Yes, it is odd since I thought that the Apple and Anker USB-C to USB-C cables would have been fully functional. I was pretty amazed that as soon as I plugged in the GoPro cable the MacBook immediately reported a new device was trying to connect.

I’m still not sure why the Admin/Serial Config option running on the emonBase didn’t work - it seems like a very good method for setting the configuration. It doen’t seem to be documented, so perhaps it is work in progress?

Sounds like those two cables may be charging cables.

i.e. the DC voltage lines are present, but not the data lines.

Ah - I get it, and I’m sure that you are correct. It is a shame you can’t readily tell the difference. Especially since turning the plug around can also be an issue. Thanks!

@Gwil - It looks as if we need a note in the documentation that a “Charging” cable is no good for data transfer.

Yes, we should make a note of that. I guess trial-and-error is the only practical way of finding out if the cable is missing the data link?

Given the near-impossibility of a continuity test in the absence of a couple of break-out sockets, I’d say yes to trial & error - or carefully read the description and/or the packaging - and assume nothing.

This page Anker 765 USB-C to USB-C Cable (140W Nylon) - Anker UK
doesn’t specifically say “charging only” - but there’s no mention of data rate, only “high speed” - data or charging? It could be either.

But this USB-C Charge Cable (2m) - Apple (UK)
specifically states “Charge Cable”.

I don’t think this is the case, all USB-C cables contain data connections, it’s part of the spec.

Some cables may be branded as ‘charging cables’ since they are rated for higher current.

I think the issue here is emonTx V4 required a USB-C to USB-A cable, it won’t work with a USB-C to USB-C cable since this requires a USB-C communication chip onboard which the emonTx V4 does not have. I’ve used lots of different type-C to type-A cables with the emonTx V4, and they all work assuming correct orientation.

1 Like

Is this the reason for the plug orientation problem?


USB-C chips e.g TUSB320 are not that expensive (£0.50 - £0.90) in bulk (ex VAT) so it maybe an option to add one in the future, but we didn’t think it was worth the extra cost, design complexity and BOM item for the minimal benefit of orientation support. The main reason to use a USB-C chip is usually to would be to access the higher current and voltages available via USB-C, obviously this is not applicable to the emonTx.

And of course, a secondary reason would be avoiding the confusion of a polarity-sensitive connector that’s not polarised and worse, widely advertised as being indifferent to the orientation.

I’ve added some more notes regarding cables and drives to the docs:

1 Like

I would suggest it could be clearer with this added:

To connect to a computer with a USB-C port, use a USB-C to USB-A cable, together with a USB-A to USB-C adaptor.

This worked for me on my MacBook!

Good idea, I’ll add that. I forgot that some computers don’t have USB-A ports.