BETA: OpenEVSE WiFi 3.x ESP32 - hardware available

Hi glyn i understand that by upgrading to the esp 32 solves the problem of no comunication via VPN on the older esp …
i was trying to find the binary file to download to the esp32 are they avalable yet .
othrwise i would like to compile this code to try it . i use the aurdino ide am i able to use this
or do i need to set up a compleat new system to be able to compile this ?
regards bill

Yes it does

Hers is the pre compiled esp32 WiFi 3.x for the esp32 huzzah Release V3.0.3 · OpenEVSE/ESP32_WiFi_V4.x · GitHub

If you want to compile you will need to use platformIO.

Many thanks I have spent the afternoon trying to find this .
I have started trying setup platformio on a Ubuntu on a pi laptop But that seems to be giving me a few issues . Think I may set up

A new install on a laptop I have spare thinking of Linux mint install

Been told that it is very good ?

Cheers. Bill

Regards. Bill

I’ve got no experience of Mint, I’ve always used Ubuntu. It should be possible to install PlatformIO with a single command:

sudo python -c "$(curl -fsSL"

What error are you seeing?

Then cd into repo then compile and upload:

cd ESP32_WiFi_v3.x
pio run -t upload

All dependences and libraries be downloaded and installed automatically.

Might want to update the shop listing to say it includes the ESP32 rather than the “Huzzah ESP8266 WiFi Module”.

I presume it’s just the software that’s under development. Hardware isn’t going to change?

We’re still currently shipping ESP8266 with WiFi 2.x in current EmonEVSE / OpenEVSE kits purchased via the shop.

The ESP32 WiFi 3.x is still in beta testing and is not yet being included as standard. This post to announce the availability of ESP32 pre-loaded with WiFi 3.x in the shop is for developers and early adopters to help us test before we make the switch.

Yep, I realise that, but the shop listing for the ESP32 you gave above says that it still includes the ESP8266.


  • Huzzah ESP8266 WiFi Module
  • UBEC 5v Regulated power module
  • Custom power & communications cable
  • Latest OpenEVSE WiFi V3 code preloaded

Speaking of which, I assume you don’t actually need to swap out the power module, or the comms cable?

What I was querying was that if I buy the ESP32 module now, it’s not going to change down the road. It’s not a custom module that you could be making modifications to?

Thanks, good spot. That’s been fixed.

Yes, the ESP8266 module will need to be swapped for the ESP32 module, the pins out are identical.

No, we’re not planning on making any hardware changes.

What was the VPN / port forward access issue that this fixes?

Is it likely that this will enable HTTPS access to the OpenEVSE?


hi glyn been a few days befor i could get to this .
i have uploaded the bin file to the esp32 and have tried several upload speed but when i power it back up i get the same error
flash read err , 1000
ets_main.c 371
ets Jun 8 2016 00:22:57

it looks like i am missing something that i have not done
I am using NodeMCU PyFlasher to upload file it compleats and reports successfull
any idears or should i use a diferant programer
thanks bill

hi glyn
sorted it followed your instrution on my linus laptop and this all worked compiled and uploaded to boards
will try fitting them tomorrow then hope full all will be good

many thanks for the help

still lots to learn

1 Like

Hi Glyn I have managed to change these boards onto my two chargers and they are now allowing me to come in via a Rpi Vpn = Win
only thing is i am finding the boards will run for several hours but then loose conection to the network … when this happens if i scan for wifi networks i find ESP_9D6015 this will let me conect to it with the adress of but does not give any webpage .
I am using the " vroom esp 32" node module . i have programed both using linux and platform io i have also uploaded the binary file you pointed me too . as a network upload .
to see if that sttoped the loss of conection/ crash to one of them they are both on and the Evse is 5.1.0.EU … Initialy i also had a problem with demandshaper not responding to them but i seemed to have sorted this by doing a reboot of the emonpi and now demand shaper comunicates with the esp32 boards …
is there a way i can compile to allow me to monitor debug via the usb port so i can log to laptop see if this will give any indication as to why they keep droping out ?
thanks for your time regards Bill Burgess

Yes, this will be available in the future. You may need to upload your own certificates.

It’s possible to monitor debug via serial2, Rx2is available on GPIO17

thanks for info
Ok I will try to set this up on the bench at present I have removed from chargers and gone back to the older esp . As charges in use daily
I can confirm that while working I could VPN into them every time untill they dropped out of WiFi

Next few days I will set up on the bench I have programmed a nano up with the ev code so I hope I can connect them to this and at least it should report lots of faults back. … but at least put it in a working environment to test

Cheers. Bill

Interesting. It appears to be working OK for me!
As far as I know, its not dropping off of the network.

I’m connecting to it via a nginx reverse proxy - its been there every time I’ve wanted to use it!

1 Like

No problem connecting to my ESP32 web interface via VPN - so I can confirm that problem is fixed. I am also seeing the intermittent loss of connectivity to the web config page, as I have reported elsewhere.

1 Like

I’ve just posted a firmware update to the ESP32 which contains a significant update to the Solar PV divert function. If any of you ESP32 beta users have solar PV and are able to test this would be much appreciated:

Please feedback to the thread:

It’s working well here.
Apart from the opencms connection always showing ‘Connected: No’
I’m unsure about the Tesla integration.
Some parts obviously have been done but, for example, ‘savetesla’ comes back with ‘not found’. Should this be in 3.2?

What is the mechanism used? If it is polling, I’m unlikely to use it anyway…

Thanks, that’s a known issue. It will be fixed.

Yes, Tesla integration is in 3.2 but only via API and MQTT. Here is the API: Tesla API support by lincomatic · Pull Request #67 · OpenEVSE/ESP32_WiFi_V4.x · GitHub

The Tesla integration does not poll or wake up the vehicle, it just gets the last values from the server. This works fine since when the car is charging the Soc will be updated regularly on the server. We plan to add a Tesla SoC display in the interface and charge limit based on %.

Yes, I saw that post.

The problem is that for me
returns ‘Not Found’

I presume the statement should actually be

http://openevse/saveteslavi?vi=VEHICLEINDEX returns ‘Not Found’

http://openevse/teslaveh works, returns {"count:"0}

http://openevse/config contains tesla_username and tesla_password but obviously blank values

http://openevse/status contains no tesla charge info.

Also, no tesla charge info added to the JSON

Good that it does not wake the vehicle but Tesla doesn’t care for their servers being polled repeatably so a streaming websocket API solution might be better?
I have some example code if interested?