Community
OpenEnergyMonitor

Community

Archive: emonSD-07Nov16 RELEASE 🎉

Tags: #<Tag:0x00007f6e013cdc20> #<Tag:0x00007f6e013cdb08>

Mmm ok, I’ll have to do some more testing. I have been unable to re-create this.

We don’t all life in the US. Personally, I much prefer the European dates dd/mm/yyy. I vote to stick with the default local and let users change if they prefer. Do you know if the Pi does any autodetection of IP location to infer NTP time timezone? I don’t think it does. When we power up a new Pi with the pre built SD card here in the UK it gets the correct time from NTP. Do you know what happens in the US? Is it essential for you to set the timezone to make Emoncms work? What happens if you don’t set the timezone? / locale?

Ok, good point. However, node-RED does work fine (and is proven stable) with the flows that we use with the version of node currently installed. I have just installed the LTS version of node so I can test. However, it was a hefty 50Mb install. I’m not sure it here is much beneft to force this on all users.

Update: installing nodejs V6.9.1 has broken my nodered :-(. I get error

nodered : Depends: nodejs-legacy (>= 0.10)

No it doesn’t change the timezone by IP, the default Raspbian OS image will be using “UTC” ie timezone not set. This will appear correct for UK users now until spring when BST kicks in as GMT is the same as UTC. if you use the date command it will tell you the timezone. Below is a stock Raspbian image before and after setting the timezone to “Europe/London” via raspi-config.

[email protected]:~ $ date
Tue 15 Nov 16:10:29 UTC 2016

[email protected]:~ $ sudo raspi-config
Current default time zone: 'Europe/London'
Local time is now:      Tue Nov 15 16:10:42 GMT 2016.
Universal Time is now:  Tue Nov 15 16:10:42 UTC 2016.

[email protected]:~ $ date
Tue 15 Nov 16:10:49 GMT 2016

Both emonhub and emoncms use UTC for timestamping data so setting the timezone should make no difference to collecting and persisting energy data (providing the UTC time is correct(ed) by NTP), the emoncms user timezone set in emoncms for the correct midnight and DST will allow data be displayed correctly etc. However the Pi’s logs including emonhub.log (not so sure about emoncms) will all be in local time according to the timezone, so they can be misleading unless the timezone is set or it is understood all logs are in UTC times.

Setting the locale would probably change the logfiles date/time formating too so there maybe some benefit for those used to the US date format, but the majority of the benefit of setting “locale” will be for “Desktop apps” which are absent from the emonSD.

EDIT - Although I can see the image creation guide mentions “setting internationalization”, I couldn’t find any reference to setting the Pi’s timezone in the “users guide” but that could well be that I was looking in the wrong place. It would be worth while users setting the timezone at least to avoid confusion with logs down the line (especially in the summer “DST” months)

I meant to check the en_US.UTF-8 UTF-8 box IN ADDITION TO the others. I did not want the US to be the only box.

The timezone is wrong with boot and NTP doesn’t seem to correct it. Once I set the raspi-config timezone and the My Account webpage timezone then all works OK. If the emonPi (or RaspPi) is suppose to be setting the timezone automatically then it is not working for me.
 

I don’t know your timezone but I am guessing it is British Time. Isn’t your timezone the same time as UTC during the winter months?? My timezone is CST (-6 hrs) now and CDT (-5 hrs) in the summer.
 

I am sure how you did the nodeJS update but version 6.9.1 may not work with Node-RED per the Node-RED google group. Only the LTS v4.6.x is fully supported.

I’ve seen the same nodered : Depends: nodes-legacy (>= 0.10) error and didn’t determine how to get fix it. I know running the update-nodejs-and-nodered command updates to LTS 4.6.x and does not have this error. I could not update the individual packages (i.e., npm, nodeJS, node red) manually and get the node-red system to work properly.

After running the update-nodejs-and-nodered command it looks like nodeJS 4.6.x (LTS) is installed via apt-get. And npm and Node-RED are installed via npm.

[email protected](rw):.node-red$ apt-cache policy npm
npm:
  Installed: (none)
  Candidate: 1.4.21+ds-2
  Version table:
     1.4.21+ds-2 0
        500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages
        100 /var/lib/dpkg/status

[email protected](rw):.node-red$ apt-cache policy nodered
nodered:
  Installed: (none)
  Candidate: 0.15.2
  Version table:
     0.15.2 0
        500 http://archive.raspberrypi.org/debian/ jessie/main armhf Packages

[email protected](rw):.node-red$ apt-cache policy nodejs
nodejs:
  Installed: 4.6.2-1nodesource1~jessie1
  Candidate: 4.6.2-1nodesource1~jessie1
  Version table:
 *** 4.6.2-1nodesource1~jessie1 0
        500 https://deb.nodesource.com/node_4.x/ jessie/main armhf Packages
        100 /var/lib/dpkg/status
     0.10.29~dfsg-2 0
        500 http://mirrordirector.raspbian.org/raspbian/ jessie/main armhf Packages
[email protected](rw):.node-red$ 

 

Enclosed is the update-nodejs-and-nodered terminal log:

2016-11-11 - update-nodejs-and-nodered.pdf (65.7 KB)

Thanks for explanation @pb66. That all makes sense.

Since settings the Pi timezone currently requires SSH it’s an advanced operation which we cannot expect all users to have the ability to undertake. It’s good to know that it’s not essential for Emoncms

It’s mentioned in the troubleshooting section: https://guide.openenergymonitor.org/setup/troubleshooting/#3-incorrect-system-time

Thanks for elaborating. I’ve had a look at the terminal pdf and as I feared:

This script will remove the pre-installed versions of node.js and Node-RED
and replace them with node.js 4.x LTS (argon) and the latest Node-RED from Npm.

I’m keen for the pre-built image to stick to using the apt version of nodered and nodejs. I think this is best for stability. As I mentioned before users can always update if they want. Maybe I could add the update steps to the oem_nodered readme to make it as easy as possible.

I am trying to use RASPBERRY PI ZERO and I have some issues comparing with May Image:

1- I can’t conect with USB wifi properly configuring interfaces file and wpa config file
2- I can’t shutdown directly, When I write “sudo shutdown” I program a shutdown for tomorrow. I don’t understand it

I will keep searching…

OK, now it is running ok. I was trying to connect wifi using wpa config file and it is easier using interfaces file only.

I shutdown again properly.

Everything it is allright! :slight_smile:

1 Like

You omitted part of the command.

It should read: sudo shutdown -h now

An easier to remember alternative is: sudo poweroff

After further successful testing emonSD-07Nov16 has now been released :tada:

All emonPi’s / emonBase’s and pre-build SD cards shipped from the shop will include this new image.

Download:

Glyn - Excellent news!
 

I am assuming the release image emonSD-07Nov16 is the same image as the emonSD-07Nov16 BETA image. And I do not need to re-download and re-image on a new SD card. Please confirm.

Thank you for your hard work!

no way to upgrade without physically rewriting the sd card ? or did I miss something (once more … :wink: )

Correct, the release is the same as the beta. Thanks a lot for you help.


As I mentioned above you can get the important updates by following:

Just installing emonSD-07Nov16, and noticed the typos in emonSDexpand:

THIS OPPERATION WILL

and:

AT LEAEST 30min

also, should be:

in an unusable

Sorry! can’t help myself :slight_smile:

Thanks for letting us know, I’ve submitted a PR for the typo’s

Thanks, merged :thumbsup:

2 posts were merged into an existing topic: No Setup->Administration option on menu

2 posts were merged into an existing topic: No Setup->Administration option on menu

2 posts were merged into an existing topic: No Setup->Administration option on menu