Community
OpenEnergyMonitor

Community

Wrong Energy


(Eduardo Rodrigues) #1

I assembled an openevse v5 with wifi firmware 2.7.6 and I’m getting the “Energy” counter measuring wrong!
It measure the power (A) ok and send it to emoncms ok in Wh but this counter “Energy” (session accumulator) in the web interface and in emoncms it’s about half of the real value!
What could it be?

OpenEvse web:

OpenEvse to emoncms:

Real value measured in house installation:


(Glyn Hudson) #2

Nice work getting up and running .

What is the version version of your open_evse controller?

Have you set “Level2” charging mode?

Does the WiFi interface kWh match the kwh on the LCD display?

Please could you post an image of the LCD display and a screen shot of you emoncms input process setup. Please post images directly on the forum rather than using a external hosting site.


(Eduardo Rodrigues) #3

The openevse board is v5…

The charging mode it’s “auto”, I test in a Nissan Leaf with a 3.6kW charger so it sets level1 16A…

The LCD display I think it’s equal to the web and emoncms readings but I can confirm later when arrive home.

The emoncms inputs I “follow” the “auto process”, I configure the openevse to send to my local RPi emoncms and import the data without changes…


(Glyn Hudson) #4

Do you know the controller FW version? It’s displayed on the LCD at startup on the system page of the OpenEVSE web page.

Ah I think this is the issue. “Auto” won’t work in the UK~ in the EU or anywhere with 240V. You need to manually select L2 as documented here: https://guide.openenergymonitor.org/integrations/openevse/

Perfect :+1:


(Robert Wall) #5

@Glyn, I think @eduardofsr is in Portugal.


(Glyn Hudson) #6

Sorry, I meant EU. Anywhere with 240V. I will correct my previous post. Sorry for the sloppiness.

Just to confirm any OpenEVSE/EmonEVSE purchased from OpenEnergyMonitor store should be running EU firmware with 'Level 2" selected by default:


(Eduardo Rodrigues) #7

Ok, will change it… seems to be that, 110v vs 230v!.



(Eduardo Rodrigues) #8

With L2 works great, thanks: +1:


(Glyn Hudson) #9

Mm that’s strange the FW version and protocol version should looks something like this:

Where did you purchase your kit from? Maybe try to restart the WiFi by clicking the “Restart” button under the OpenEVSE WiFi version shown above.


(Eduardo Rodrigues) #10

I bought it here: https://openenergymonitor.com/openevse-v5-controller-pcb/

Maybe I should update the firmware…


(Glyn Hudson) #11

Ah right, individual OpenEVSE controllers were shipped with the default firmware. We have now started shipping all with EU firmware.

No need unless you really want some of the new changes (mostly minor bug fixes). The main difference is just the default setting which you can easily change e.g Level 2.

See the EU FW change log; https://github.com/openenergymonitor/open_evse/releases/