Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Wrong CT readings

Hello,
I am not understanding the readings of the CT.
Hardware: emonpi + YHDC SCT-013-000 (100A:50mA).
I have a small homelab with an standard power meter plug to compare the readings.
The output of the power meter is about 500W, whereas the one from the CT is between 15 and 20W.

What I did:
The CT is connected to the same cable from which I am reading ~500W with the power meter plug
The CT is closed correctly
I have restarted after connecting the CT & AC adapter.
VRMS reading is 240 ( I live in Germany)

After seeing this I connected the CT to the main line of my apartment, the readings are about 300W to 400W, I know for a fact that the current consumption is higher than that.

I also tried to check with a vacuum cleaner (600W), connecting the CT to it (also winded the cable 2x and 3x) with almost no change on the readings.

What am I missing?
Can I assume that the CT is not working properly already or is it possible to do any more troubleshooting with the emonpi?
Thanks in advance
Cheers

Welcome, Samuel, to OEM.

I am sorry you are having problems.

Does the c.t. read the same in both inputs of the emonPi? (You must power down completely if you change to the second input. The “emon” part of the emonPi is not reset when you reboot the Raspberry Pi.)

Have you changed anything in emonCMS - especially in Emonhub → Edit config?
Look at this section

[[5]]
    nodename = emonpi
    [[[rx]]]
        names = power1,power2,power1pluspower2,vrms,t1,t2,t3,t4,t5,t6,pulsecount
        datacodes = h, h, h, h, h, h, h, h, h, h, L
        scales = 1,1,1,0.01,0.1,0.1,0.1,0.1,0.1,0.1,1
        units = W,W,W,V,C,C,C,C,C,C,p

and check that it is the same.

Do you have a meter capable of reading less than 50 mA a.c.? If you do, you can connect the meter to the tip and sleeve ( ‘left’ and ‘common’ if it was audio) of the c.t’s plug, then clip the c.t. onto a cable, and you should read 0.5 mA per 1 A of current in the main cable.

Hello Robert,
Thanks for the quick answer.

I didn’t mention it before, but I tried with both CT1 and CT2, there was a delta of around 5 W (average), being CT2>CT1. I thought it wasn’t relevant.
I haven’t changed the config file, it is the same as the one you showed.
I don’t have a multimeter, I am getting a second CT (I needed a second one, in any case), I’ll check with it and I’ll come back to you.
Thanks!

It’s not totally irrelevant - there are some things common to both CT inputs, but also common to the voltage input, and that is correct. So knowing that the two inputs are nearly the same (5 W is noise) almost eliminates a fault with one input. Of course, it could be a manufacturing fault that’s affected both inputs - but unlikely.

You have of course put the c.t. on a single wire, and not on a two-core or three-core cable?

I’m sorry if that is a stupid question and an insult, but sometimes it happens. I don’t think it is likely that you have done that because the reading on your main incoming cable is too high for that, unless you have a 3-phase supply and you put the c.t. on the neutral (blau) cable?

If you are using the c.t. correctly, it does look very much like there’s something wrong with it. Whatever the result, either the c.t. is wrong, or both c.t’s are wrong, or your emonPi is wrong. Email the shop: [email protected] and link to or mention this thread.

using the c.t. correctly

Which includes ensuring the CT plug is fully inserted into the jack on the emonPi.
As the OP has tried connecting his CT to both inputs, the chances of that being the problem are
quite slim. But, leave nothing to chance.

The OP contacted us via email with photo of the installation, the CT was clipped round both the Line and Neutral.

1 Like

That’s been known to produce unreliable (and largely meaningless) readings. :roll_eyes: