Community
OpenEnergyMonitor

Community

Wifi relay Temperature sensor do not work in AP mode


(Juan Dorado) #1

Hi, i am testing the new WIFI Relays that you send. I found two working bug.
if i set the wifi relay in mode AP, the temperature sensor does not work, shows “NaN”.

If i connect the wifi relay to the router but the router has not internet connection, the temperature sensor works but, in the schedule mode the relay does not change (ON-OFF-ON).
If i connect the wifi relay to the router with internet connection, everything works well.

I want to use it in mode AP. Any solution?

The firmware is 2314.

Thanks.


(Martin Harizanov) #2

AP mode is only intended for configuration of the unit, the temperature sensor daemon doesn’t run in that mode as there is no connection to the internet and nowhere to report the temperature reading to…

WiFi connection is required for the scheduler to work, as the unit requires NTP (network time) to determine time and day. Without it, it simply doesn’t know what the time is and can’t process the schedule. NTP is necessary at least during startup, after that, it is not needed (other than syncing from time to time). You can still use it to manually switch on/off the relay, but no schedule function without knowing the time.


(Juan Dorado) #3

Hi, thanks for your quick answer
i supposed that, but i read in this link > https://openenergymonitor.org/emon/modules/wifirelay
what the wifi relay can be used in AP mode.
and i was confused for that.

thank you again and all ok.


(Glyn Hudson) #4

I will add clarification to documentation


(Bernardino Morillo Merino) #5

I have a huge problem related to the wifi relay scheduler.

I have 5 relays in the same situation.

Manually the relay ON/OFF works fine, also with the temperature Manually control, but when I use scheduler it does not work.

The problem is that.

When the temperature relay is working the temperature SET POINT turn RED and the relay switch ON/OFF, but when i am using scheduler the set point change fine but it does not turn red and swich does not make anything.

The relay is properly connected to internet and time and day are recognized perfectly.

Please I need any help with this!


(Bernardino Morillo Merino) #6

The problem is that:

NTP Client is not working

When I connect to NTP Settings the time is: 1/1/1970

How to fix it?


(Bernardino Morillo Merino) #7

Ok I restart it and now I have the correct time and I think it is working fine.

I will keep informing.

Thanks.


(Bernardino Morillo Merino) #8

Now it is working fine.

The problem was that:

I was reading the correct time in the schedule page, however NTP was uncorrectly configured (1 hour less than shedule time) and it was not working. I have to correcto the NTP configuration and then restart and check the time in NTP page.

Thanks.


(Bernardino Morillo Merino) #9

I see I can set only 8 time steps per day in Schedule temperature control RELAY, isn’t it?

Anyone know how to enhance it if it is possible?

Thanks.


(Glyn Hudson) #10

Nice work figuring out the ntp issue. I’m not sure if it’s possible to modify. Do you know @Martin_Harizanov?


(Martin Harizanov) #11

Hello,
the 8 schedule segments per day are hardcoded at the moment, changing that won’t be trivial I am afraid. You can easily work around this limitation by implementing externally schedule in node-red for example, and controlling the relay via MQTT or HTTP requests as per the documentation, but you’ll lack the nice UI…

Worth checking:


http://tech.scargill.net/tag/a-node-red-dashboard-thermostat-in-the-making/