Wifi connection - OpenEVSE

Hi guys,

We connected the OpenEVSE on our Wireless Network. After that, We lost the HTTP access. We are able to ping the new OpenEVSE IP, but we can’t access it via browser. Do you know how to fix it?

Thanks.

Do you mean it was first connected via a wired connection and it worked? If so the WiFi connection will be a different IP address.

We connected by wifi to ip 192.168.4.1,
we create a local wifi network and provide a new ip address changing the
192.168.4.1 to the new one. After that we lost the to openevse.

I’m not exactly sure what you mean here unfortunately. @TrystanLea @glyn.hudson can you help?

Hi @Geinian, nice work connecting the OpenEVSE WiFi to your network. I’m assuming the web interface worked fine in AP mode when connecting to 192.168.4.1? It’s very strange you no longer have access to the web interface when browsing to the IP address on your local network.

If you power cycle the OpenEVSE does you local IP address appear on the LCD?

To reset the WiFi module to disconnect it from you local network and put it into AP mode again hold down boot / GPIO0 button on the ESP8266 module for about 5s will force WiFi access point mode.

Do you have a different WiFi network you can test to connect to?

If you’re still having issues then it sounds like you have a faulty WiFi module. We could try and send out a replacement Wifi module for you to test with.

Hi,
After upgrading the wifi module (Adafruit HUZZAH ESP8266 breakout) firmware from 2.7.8 to 2.8.1 I am not able to access it anymore, it’s bricked. No SSID is being broadcasted and it’s not connected to my network. Upgrade went successful as per the message on the display.
We’ve bought a programmer USB to UART and followed some guides to write a new firmware to the flash but it’s not working. We’ve hold down the GPIO0 button, clicked the reset button then released the GPIO0 to enter bootload mode but not sure whether it worked.
Tried transferring the file using esptool.py on Linux and esptool GUI on Windows. We are getting connection failure messages on both cases. The module’s blue LED blinks during the connection phase.
That’s how we have connected things:
TX and RX pins going to the programmer and GROUND and V+ to the Arduino.

This might help:
Connect the +5V and GND from your USB->TTL programmer to the ESP8266 module - disconnect it from the EVSE supply first. The Rx and Tx as you have connected it - RX(Programmer) to TX(ESP) and TX(Programmer) to RX(ESP). Not connecting ground can be the reason it will not flash as you are powering the ESP from a power supply that does not share the same ground plane as the USB port of the PC.

@Steven_Bense is correct. You will need at least GND from the programmer. I would recommend connecting both VCC and GND from your programmer with the module disconnected from the OpenEVSE

Hi,
When I set the IP adress to an internal network IP, I lose access in OpenEvse.
The default IP is 192.168.4.1 and I changed to an internal network IP the was reserved to this equipment.
Every time we connect to a different IP in OpenEvse we have to reset the module because it is inaccessible to the network, how to solve this problem?

To ensure the OpenEVSE uses the same IP address each time you will need to reserve it’s IP address via your router. Alternatively you could access via the hostname which should work irrespective of IP address http://openevse or http://openevse.local. Local IP address lookup does not work on all networks.

What WiFi router are you using?

There is a reserved ip, I just can’t access the openEvse interface through this ip.
the device generates the new ip but does not access the graphical interface
every time I turn on the device it generates the same ip 192.168.0.62
which is from the internal network.

You need to go into your router and expire the lease on that IP Address and then reserve a different IP against the MAC address of the OpenEVSE.

This is an issue with your WiFi / DHCP server not the OpenEVSE. The OpenEVSE just takes the IP Address the Router/DHCP server gives it.

1 Like

I think I might be seeing the problem that Geinian was trying to describe.
I was able to connect web interface on the openevse network (192.168.4.1). At this point I told the openevse to connect to my wifi network where it was given the IP address 192.168.1.142 (confirmed on the access point list of wifi clients)

I then tried to point a web browser at http://192.168.1.142 and got nothing. I have done a tcp dump of the network interface to see what is happening, and the openevse acks the browser get request but does not return any data (see below) The openevse then trys to resets the tcp connection. If I force openevse back to advertising its own network by turning off my access point then I can connect to the web interface just fine.

21:47:20.572894 IP 192.168.1.104.38780 > 192.168.1.142.80: Flags [S], seq 1673826079, win 29200, options [mss 1460,sackOK,TS val 764089525 ecr 0,nop,wscale 7], length 0
E..<."@[email protected]|.Pc.........r..u.........
-...........
21:47:20.578662 IP 192.168.1.142.80 > 192.168.1.104.38780: Flags [S.], seq 326816, ack 1673826080, win 5840, options [mss 1360], length 0
E..,...............h.P.|....c.. `...v......P..
21:47:20.578732 IP 192.168.1.104.38780 > 192.168.1.142.80: Flags [.], ack 1, win 29200, length 0
E..(.#@[email protected]|.Pc.. ....P.r..a..
21:47:20.578983 IP 192.168.1.104.38780 > 192.168.1.142.80: Flags [P.], seq 1:322, ack 1, win 29200, length 321: HTTP: GET / HTTP/1.1
[email protected]@..#...h.....|.Pc.. ....P.r.....GET / HTTP/1.1
Host: 192.168.1.142
User-Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Connection: keep-alive
Upgrade-Insecure-Requests: 1


21:47:20.648402 IP 192.168.1.142.80 > 192.168.1.104.38780: Flags [.], ack 322, win 5519, length 0
E..(...............h.P.|....c..aP....f........
21:47:25.701881 ARP, Request who-has 192.168.1.142 tell 192.168.1.104, length 28
........P{.......h..........
21:47:25.703883 ARP, Reply 192.168.1.142 is-at 84:f3:eb:70:15:ce, length 46
...........p......P{.......h..................
21:47:30.822336 IP 192.168.1.104.38780 > 192.168.1.142.80: Flags [.], ack 1, win 29200, length 0
E..(.%@[email protected]|.Pc..`....P.r..a..
21:47:30.823781 IP 192.168.1.142.80 > 192.168.1.104.38780: Flags [.], ack 322, win 5519, length 0
E..(...............h.P.|....c..aP....f........
21:47:41.061848 IP 192.168.1.104.38780 > 192.168.1.142.80: Flags [.], ack 1, win 29200, length 0
E..(.&@[email protected]|.Pc..`....P.r..a..
21:47:41.064841 IP 192.168.1.142.80 > 192.168.1.104.38780: Flags [R.], seq 2, ack 321, win 5840, length 0
E..(...............h.P.|....c..`P....!........

Sorry I should have said
WiFi Firmware
ESP8266
Version: 2.8.1

Did you try a reboot?

As an aside tshark is another great tool for capturing network traffic.

I have power cycled several times. I have also tried the reset button on the wifi board. I have not tried a reboot using the evse button as I don’t currently have one fitted as I was planning to have a wifi only controlled unit.

Agreed on tshark I am just in the habit of using tcpdump as it tends to be on a lot more machines in the office.

1 Like

I just thought I would follow up on this one. I found the problem is that my wifi DHCP server was advertising a 1400 byte MTU due to my internet traffic being tunnelled. This seems to break the openevse wifi module. As soon as I set the DHCP MTU size to 1500 bytes it all works perfectly.

2 Likes