Community
OpenEnergyMonitor

Community

WiFi connection issues

wifi
Tags: #<Tag:0x00007f1fe1ddcfe0>

(Jon Starbuck) #1

Since updating my emonPi to the new October 2018 version I have been unable to get it to connect to WiFi.
Pi is a 2B. It appears to works just fine in every respect once the two last lines were removed from /boot/config.txt… other than the Wifi won’t connect! I checked and rechecked the SSID and Password, they were fine… It can see my router, it just stubbornly refused to connect.
Yesterday I gave up, assuming it was my own ineptitude. I backed up the data and reflashed the SD card. It connected immediately once i had set up WiFi… and then overnight it dropped the connection, I restarted it and it was OK but while I was out at work it dropped the connection again, restart and the WiFi connection is back up again.
It does not look right - while there is an IP address showing there is no MAC address, nothing showing in the Network Log… !
I bet it drops again in a few hours, in the meantime is there anything I should be doing or looking at? I can connect via a wired connection after wifi drops.


(Nicolas Piquemal) #2

I had an issue as well, maybe related to your problem, maybe not.
For me, with the same release (october18), impossible to connect to the WiFi when pressing “Save and connect”. Nothing happened. Even clicking the “Start, Stop, Restart, Refresh” buttons. The connection info was empty.
I had to reboot the raspberry twice to get the connection work.


(Jon Starbuck) #3

Hi, That is a good description of it, only a reboot seems to solve it.
It keeps logging, just drops WiFi. Wired ethernet and no problems.
What Pi to you have, I wonder if that is related?
It is running now, its been up for about an hour - I’ll come back to this post if/when it drops the WiFi again.


(Greebo) #4

Since the Pi2B doesn’t have built-in WiFi, what WiFi adapter are you using? Perhaps it is related to that?
There may be an incompatibility with the specific adapter and the drivers included on the latest image…


(Nicolas Piquemal) #5

I have a Pi3B


(Trystan Lea) #6

I’ve recently had an issue where the Pi maintains connection over WIFI but becomes unreachable via both IP address and hostname. Ongoing connections e.g OpenEVSE -> EmonBase MQTT socket connection stays active and posting to emoncms.org. Rebooting the router fixes the issue. Its a BTHomeHub. Its likely a different issue though, but I think something worth checking for anyone else experiencing WiFi issues.

What WIFI adapter do you have @stabuck?


(John Banks) #7

I have 4 emonTx’s monitoring a large PV installation and have had intermittent wifi problems with both the Oct 2018 image and earlier images. The router is a BT HomeHub.

I’ve implemented several attempted fixes and, as I write, wifi has been OK for a week – so famous last words?

Suspecting the BT HomeHub, I changed from using fixed IP addresses to using DHCP and then used host names wherever applicable as an alternative.

An example: but just in my case, ‘emonpi-node-13’

Power Management can be a problem with wireless adapters - to turn it off …

Add the following line to /etc/rc.local just before the final exit line …

sudo iwconfig wlan0 power off

The popular Edimax wireless adaptor can be a problem and so do the following in a terminal …

sudo nano /etc/modprobe.d/8192cu.conf

then add the following lines …

# Disable power management
options 8192cu rtw_power_mgnt=0 rtw_enusbss=0

(Thx to Mr Engleman for these suggestions)

But that’s old advice as I’ve recently read the Edimax has driver problems with Stretch (on which the Oct 2018 image is based). This link proposes a solution …

https://edimax.freshdesk.com/support/solutions/articles/14000032146-how-to-install-ew-7811-ac600-series-and-ew-7822uac-adapters-on-raspberry-pi

But that all seems OTT to me. An alternative to Edimax might be a simpler solution. I’ve upgraded the RPi’s to the latest model which includes on-board wireless for the 2 nodes closest to the router.

Lastly – and a lateral thought – wireless adaptors consume a lot of power – is your PSU man enough? I use the official RPi PSU to obviate that potential problem.

Happy to add further detail – this Forum has been a great help to me in the past.