Wifi-check script ignores ethernet


I’ve just started using the new emonSD-03May16 image and I had decided to use wired ethernet for a while so I downed the wlan interface to ensure the Pi would only use the ethernet port. So I was surprised a few minutes later to find wlan was up again, which I tracked down to the wifi-check script in /home/pi/emonpi.

When I reviewed the script, I found it has logic to check if the wired ethernet was active before it enabled the wlan interface, but this code was commented out.

Any ideas why?


It was found that some users wanted to have the unit connected to both wlan and eth0 at the same time. I suppose this is not normal operation but it’s certainly useful for testing! Feel free to uncomment the code on your system.

Would this be someting that could be set as an option either in the admin page or in settings file? At least it should probably be clear that this is what the emoncms system does in the documentation.