WiFi APs rebooted, now emonTX won't write to emonPi

Good evening,

I’ve just noticed that my previously working fine emonTx with emonESP is no longer writing data to my emonPi emonCMS instance. This has been since last night.

The only thing that changed last night is that I rebooted my WiFi APs.

I could access the emonTX via the IP address and could see that it was happily reading values from the pulse sensor and CTs and attempting to send these (the message counter was increasing) but the success counter was not and the emonPi input for this emonTx was showing red.

The emonPi is wired and is accessible without error via IP. Another emonTx I have (radio connected as right next to the emonPi) is working fine. The emonPi is also writing data out to emonCMS internet instance.

So I am discounting network problems as all devices are accessible as expected.

Things I’ve tried:
I have restarted emonHub on the Pi
Restarted the emonPi
Restarted the emonTx
Deleted the emonTx input on the emonPi
Factory reset the emonESP
Reconfigured the emonESP (it’s seeing the pulse and CT values again)
Rechecked the guide - Using the emonTx v3 with the ESP8266 Huzzah WIFI module - Guide | OpenEnergyMonitor

After all that I’m still back to square one with the Input now not being created on the emonPi and monitoring for my heat pump offline.

Can anyone suggest anything else to look at in order to get this working again?

And can anyone explain why losing WiFi for the time it takes an AP to reboot would cause such hassle?


For confirmation, I’m only using IP addresses, so the problem is not DNS.

I’ve also tried to set up mqtt but that is also failing to connect. Though this wasn’t configured earlier and I don’t knowingly use mqtt on the emonPi so there may be another reason for this.


So I rebooted the ISPs router. Input immediately appears.

Wasted evening.


Have you set fixed IP addresses in the router for everything? That’s usually advisable.