Weird issue with latest emonSD-21Jul21 (Stable)


I’m using a physical EmonPi, with the latest version of the prebuilt SD: emonSD-21Jul21 (Stable)

I’ve dd’d the image to a number of SD cards, and found that no matter how many times I try, as soon as I set up Wifi or plug in Ethernet, the EmonPi card corrupts (resulting in a message during Pi boot of Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block.

On boot, the EmonPi simply shows a message saying booting...

I had been running a happy EmonPi for months, and noticed after a power cut (read: reboot) that this issue occurred, I’m only realising now that this isn’t an issue with my SD card, but with the latest SD card, Raspberry Pi OS, and whatever updates are applied after initial setup.

Is anyone else seeing issues using the prebuilt SD with vanilla setup?

I tried to use fsck.ext4 to fix the panic, but the result is a message saying:

Input/output error while recovering journal of rootfs
No medium found while trying to open /dev/sdb2

The superblock could not be read or does not describe a valid ext2/3/4 filesystem.

Again, I can replicate this by imagine the latest prebuilt to an SD card, putting it in any EmonPi I own, booting initial setup (via Wifi or Ethernet), then near immediately Apache gives a 403 Forbidden and next reboot yields the disk corruption issue I mentioned above.

Any ideas?

Hi John,

Not been reported before.

Have you tried downloading the image again?

Have you got a bare RPi you could try it in?

Plug Ethernet in before boot?

There is a resize operation that happens on first boot so perhaps that is getting interrupted. Can you plug in ethernet and boot and leave alone for 30 minutes?

@TrystanLea @glyn.hudson

Testing all these angles thanks.

I bought a new SD card just for a sanity check and got further, but now have this issue: Newly installed EmonPi shows all inputs as n/a - #4 by John_Woods