Community
OpenEnergyMonitor

Community

Vrms drops to zero - no more data

I have just bought an emontx. It worked fine for a couple of hours, then the Vrms and P1 dropped to zero, and never recovered. After a reset all is fine for another few hours, when the problem repeats. The interval is fairly random.
One CT
AC adapter
Powered by USB
ESP8266 attached (emonESP firmware)

Any ideas?

Welcome, Al, to the OEM forum.

I’m sorry you seem to have a problem. A faulty a.c. adapter, socket, barrel plug are the first things I’d check, because I’ve never heard of that particular fault before.

That implies other data carried on regardless - is that correct?

Where are you seeing the data?

What do you have in the the way of test equipment in order to diagnose the fault?

yes, it kept reporting, but just zeros:
The data is from an ESP8266
I have a USB->UART bridge, multimeter, etc

Log from emonESP:

2020-04-10T10:35:52.976Z MSG:150,Vrms:246.31,P1:-1501,E1:4294966701,pulse:0
2020-04-10T10:35:54.067Z MSG:153,Vrms:246.32,P1:-1500,E1:4294966689,pulse:0
2020-04-10T10:35:55.138Z MSG:154,Vrms:246.33,P1:-1510,E1:4294966685,pulse:0
2020-04-10T10:35:58.405Z MSG:158,Vrms:0.00,P1:0,E1:4294966685,pulse:0
2020-04-10T10:35:59.474Z MSG:161,Vrms:0.00,P1:0,E1:4294966685,pulse:0
2020-04-10T10:36:00.569Z MSG:164,Vrms:0.00,P1:0,E1:4294966685,pulse:0
2020-04-10T10:36:01.643Z MSG:166,Vrms:0.00,P1:0,E1:4294966685,pulse:0
2020-04-10T10:36:02.734Z MSG:167,Vrms:0.00,P1:0,E1:4294966685,pulse:0
2020-04-10T10:36:05.966Z MSG:170,Vrms:0.00,P1:0,E1:4294966685,pulse:0


Pressed reset:

|2020-04-10T10:40:49.414Z |i4Cal = 16.67|
|2020-04-10T10:40:50.024Z |’+++’ then [Enter] now to enter config mode…5s|
|2020-04-10T10:40:55.373Z |CT1 detected, i1Cal:90.90|
|2020-04-10T10:41:05.450Z |AC present|
|2020-04-10T10:41:06.077Z |MSG:1,Vrms:244.94,P1:-1360,E1:4294967293,pulse:0|
|2020-04-10T10:41:15.913Z |MSG:2,Vrms:244.87,P1:-1354,E1:4294967289,pulse:0|

(-ve as exporting from solar PV - issue occurs when +ve as well)

That’s weird. I’m not familiar with the ESP8266, but I wouldn’t expect a fault there to give those symptoms.
But one thing is puzzling me - normally the emonTx reports every 10 s, yours appears to be reporting every 1.1 s approximately. Which sketch are you using, and how have you changed it?

I do notice that there are 3 seconds and three missing messages before it comes back with zero voltage, and then one or two missing messages between successful ones, which suggests a possible power loss/brownout and reset.

Notwithstanding all of that, if you disconnect the ESP and look directly at the serial output via your programmer, does voltage and power still disappear?

Hi,

its the EmonTxV3CM Continuous Monitoring firmware which it came with (this looks right when I boot it connected to a programmer). I haven’t changed it.
The ESP8266 is flashed with this: https://github.com/openenergymonitor/EmonESP
I’ll try connecting a laptop to it via the programmer and see if the problem occurs. It may take a few hours.

Thanks.

Looks like it was the ESP8266. When I linked it to a laptop it worked for a few hours, so I swapped in a Pi zero, with a script to send data to emoncms, and it worked fine all night. fingers crossed that was it.

Thanks for your help.

I did PM Trystan as it’s his sketch in the emonTx and I think he knows about the ESP8266, but he hasn’t come back to us yet.

Is it now reporting every 10 s as it should, rather than every second?
Why I ask is I’ve a vague memory of someone else having trouble with an ESP, and they took out the live configuration/calibration facility. From that, my guess is the ESP is sending random stuff back to the emonTx when it shouldn’t, but I can’t prove it.

1 Like

yes, it is reporting every 10s now. I agree that it looks like something was going back to the emontx from the ESP that upset it. Its still working well with the Pi serial connection.

2 Likes

I meant to point this out earlier - The large number you see for your energies is because the sketch uses unsigned long for the type when packing the data to send in the payload for the radio, when in fact the library correctly returns a long (signed).

You should have seen a negative energy because you were nett exporting at the time.

Good to hear that you have it working with the serial connection @alcowie. I’ve made a note here to look at this in more detail https://github.com/openenergymonitor/EmonLibCM/issues/3

I still think these emonESPs are more trouble than they are worth. A PiZW would do just as well IMHO.

1 Like

Its been working perfectly with the Pi Zero since I swapped that in. However, I do like the ESP8266 idea, as I use those for other little projects I have going.

Thanks again for all your help.

1 Like

Better when one considers that it’s capable of running an actual OS.
Especially for what they cost, not to mention the community behind the entire RPi product line.

1 Like