Vaillant Arotherm Owners Thread

I set mine to -100 and it did decrease the starts, but not by very much. An additional 40degmins during the compressor off period seems not to amount to very much, particularly as it looks like Vaillant’s algorithm calculates degree30secs rather than degreemins (on my controller at least).

I tried, but looks like this setting is ignored on mine at least. The heating pre-run and pump clearly start at -60 still, even after a reboot of the system. Did you actually see it drop to -100 after setting change, but not before. I also noticed that it seems to use degree30secs when counting down, when heating comes on though and it starts counting up, this seemed to be in degreemins.

This graph is with -100. The pump (brown) comes on for pre-run when the integral (green) drops to -60. The compressor (purple) kicks in just after this. So it’s clearly ignoring the -100 configuration. I haven’t gathered the data for -60 or -30 for comparison yet.

I’m still struggling to get ebusd data into EmonCMS so have to use the live monitor menus on the Unitower. The degmin on this update every 30secs up and down. I’ll check whether the -100 setting is still being honoured: haven’t looked this heating season.
As an aside, I ended up setting schedules for my heating. The passive house changes temperature very slowly, so instead of running the hp continuously with target of 20C I now schedule 20C for morning, 20.5C for evening and 19.5C overnight. The COP (Vaillant reported) is much higher (high 4s to low 5s) compared to 4 last heating season. This is down to longer running periods on the compressor, fewer cycles and the circulation pump being off for the night “setback”.

I have 7kW in 300m2 passive house which in hindsight is over-sized. If 7kW was the max output (and it modulated down to 25% of this) it wouldn’t be so bad, but thats not the way it works with Vaillant. I agree that another way to limit cycling is via scheduling and/or external controls which force more constant output during some periods and turn it off during other periods. My UFH is in 200mm passive slab, so the timing of when heat goes into the slab isn’t critical.

The other thing is that idle usage in “active” is 90W on my install given I have a post-buffer pump and this impacts overalll COP when low heat demand. On the flip side though, it does help move heat from south-facing rooms to noth-facing, just a shame no way to reduce the power of internal pump at same time as main pump.

Let me know if you need a hand polling/pushing ebusd data to emoncms, I’ve managed to get that up and running.

Just checked my emoncms data, it does count-down correctly when you look at it over time. I got the same impression as you that it was decreasing too fast when monitoring via dispaly, but looking at the graphed data I think it is correct.

I don’t have a buffer but there is an additional pump on the flow (which is probably excess to requirements by my calculations). This switches with the Arotherm internal pump, but only when in heating mode. Rightly or wrongly, this is on x16 main board connector of the Unitower.

I’ll be interested to confirm the degmin via ebusd (thanks for offer of help), as the live monitor value was definitely changing every 30secs by the value of flowtemp-target flow temp.

Be very interesting to see if “-100” works for you too.

I have a simple python script that pulls data from ebusd every 30s via calls like this:

integral = subprocess.check_output(“ebusctl r -f Integral”, shell=True, stderr=subprocess.STDOUT).decode()

(I pull individual parameters because polling all of them in one go takes time if you force refresh and if you don’t force refresh then data can be stale, especially thinks like integral which aren’t updated via events I don’t think)

and then posting to emconcms using it’s Emoncms - input api’s before creating graph like the one I posted above.

Pull the plug on it and see if everything still works and flow rate is high enough? I also have an (unplugged) circulation pump that shoud never have been installed. In my case circulation pump isn’t required because each mixed circuit has a pump which pulls from buffer via mixer valve.

Have tried switching to ‘Active’ for the last 2 days, both mornings have been sunny - i can’t really tell any difference to having it set to ‘Inactive’ the flow temps seem to still just target the heat curve… We just have radiators as emitters but i find that ‘Expanded’ has too much of a lag before the HP fires up again after the temperature drops below the desired temp

You’ll see a difference if the house heats up due to solar gain. The room temperature seen by the controller will rise and the target flow temperature will drop to compensate (vs. ignoring the actual temperature and just following curve based on outside temperature which is what “inactive” does). You don’t want to have the controller in a room that gets direct solar gain though, otherwise this will work against you and the other rooms may be colder than you want.

yeah the stat is in the middle of the house and doesn’t get any direct solar gains, will keep it on active, maybe i’m just too impatient!

1 Like

@dfeist Finally got some heating demand! You are right, the compressor starts at -66degmin here with compr.start.heat from set at -100degmin. The Live monitor degmin value then changes every 30 seconds by the delta between the target flow and flow temps. I will (eventually) set ebusd: thanks for the tip.

From my observations the heating pre-run (and pump) starts at -60degmin, and the compressor kicks in shortly afterwards. The compressor doesn’t start without first ramping up the flow-rate, so thats why you see -66degmin.

I see it dropping by the delta every 30s on live monitor too, but it I collect the data and graph it over a period of time it does actually reduce the integral as expected using degmin and not deg30s.

Interesting yours doesn’t respect the -100degmin either. This point to a Vaillant bug in funcionalty that is clearly documented in the manual and which should help extend cycle times which is annoying.

It’s interesting you see different changes on the display and via ebus for the integral - wouldn’t that mean the two values diverge as time goes on in a cycle? There were quite some discussions in german forums regarding the 30s energy integral behavior and it was deemed a bug that was apparently fixed with the 9.02 software version of the heat pump. Some people even got control boards replaced for that.

Found the threads. Very interesting indeed! Some very annoyed german arotherm owners who think this is a bit like an emissions scandal. Seems that most people are having to pay for their own replacement circuit boards (unless they can get the board replaced for another reason) as Vaillant are not acknowledging the issue! They also report that -100 degmin doesn’t work and it always uses -60 which is what I have observed. (I need to put mine back to -60 and retest, but it could be that using -100 is slowing down the counting somewhere, because I’m sure I saw the same as @AndyS and the those on german forum before)

This is one of the threads which includes a comment on page 3 with a before and after comparison showing reduction from 16 to 6 cycles overnight! See: Vaillant Arotherm Problem Energieintegral? - HaustechnikDialog

I assume we’re all running the old version. I’m on “351.06.06”. @Zarch I know you like digging into the details, what version are you running? And do you see the incorrect counting of integral on your 5kW?

As independent confirmation that newer software versions work as intended: I’m on 0351.09.02 and switched to -100°min this morning. It works as intended, all cycles since go to -100. Integral roughly aligns with an independent calculation using flow and target flow temperature:


Does yours also count up and down correctly too? I still can’t get my head around how 0351.06.07 counts but it’s definitely counting double for -60degmin, with -100 it’s a bit more confusing.

Out of interesting do you see roughly 50% as many cycles using -100degmin? Have you had you board replaced to get 0351.09.02, or is unit newer and come with this version?


Just checked, 351.06.07 here. So just a small revision above yours?

I’ve not messed with the comp settings yet.

Is the only way to upgrade the software with a board swap? No way of flashing the board?

It came with this version, was installed in November last year. Counting appears correct in both directions and the -100°min setting definitely leads to fewer and longer cycles - with the accompanying stronger over/undershoots of room temperature.

It won’t be half the cycles as it is looking at the area under the curve for each cycle’s flow vs target temp. Since the flow temperature is dropping over time, the additional 40°min is accumulated faster than the initial 40.

Right. -100degmin on yours will have quite a bit longer cycles than -60deg on old version though!! In my case i’m not worried about any under/overshoots of temperature as UFH is in 200mm concrete slab and room temp is very slow to react, so this would have zero impact.

There is a risk that, starting from -100degmin, compressor runs hard initially and this impact efficiency, but in my case I’m running with noise reduction on permanently which will mean this won’t happen. Would be interesting to add compressor rps to you graph though!