Vaillant Arotherm Owners Thread

FYI … using ebsud I’m able to generate all the data for the emon heat pump app (and populate data to heatpumpmonitor website - which will upset the heat meter purists ! )

emontx3 for the ASHP power usage

ebusd provides:

  • flow, return temps (with flow rate used to calc instantaneous power)
  • room temp
  • yield (add power to get heat kWh)
  • flow rate


I’m not sure about much of this yet, haha.

Hi folks, here’s a question:

During the recent cold/damp snap we had recently, we had the worst defrost cycling (and thus performance) from our 12kW AroTherm+ that I’ve seen since our installation in late October (combined heating/DHW CoP daily minimum of 2.8, down from an average of 3.9). Subjectively it seemed worse than the (colder) cold snap at the start of December - this time we had crazy freezing fog and half-inch long hoarfrost on everything, so the high humidity clearly wasn’t helping things!
But the main thing I noticed was that for the first time, the heating was undershooting the target temperatures by a degree or two. Yet the flow temps looked similar to normal (mid-30s), so I think it had plenty of headroom to boost the power if told to do so.


  1. Am I right in thinking that the AroTherm’s control software does not compensate for the energy input to the house missed while it busy defrosting? (I think this is the case from the observations above.) This seems like a missed opportunity, as it seems like it would be a fairly trivial addition in the controller firmware along the lines of “defrost cycling at X cycles per hour → boost flow temp by Y degrees”.

  2. What is the best strategy to avoid undershoots in similar situations in future?
    a. Accept that I need a slightly higher heat curve permanently? (Currently 0.6 - works fine and comfortably 95% of the time);
    b. Temporarily adjust the heat curve up when the weather looks bad (annoying);
    c. Just manually override the target temps up a degree or two when it gets cold?

Interested to hear your thoughts…

I have seen the same issue with my 5kW unit, however it is dryer here so far than during the early Dec cold snap. The worst is got then was defrosts every 35/40 mins or so. I was considering manually setting a higher flow temp or indeed tweaking up the curve, but haven’t had to resort to that this time round, yet. I agree it doesn’t seem beyond the wit of man to have the unit be aware of its defrost history and adjust flow temp automatically to account for the defrost ‘downtime’.

1 Like

Just had a heat pump installed (5kW with a 300 litre Joule tank) and am still tweaking the settings. With respect to the hot water settings, the default value for the charging offset is 25 deg which I though was a bit excessive so I reduced it to a value of 10. I currently heat the hot water to 52 deg and allocate a 3.5 hour period at night to heat the water. I was thinking of reducing the offset value further but would be interested to know what other are using for this setting.

Thanks for any feedback.

What mode do you have the circuits on? Inactive, Active or Expanded?
I find Active the best when it gets cold - especially for reducing defrosting / increasing CoP. Means it runs 24x7. This is with a 1.5C setback overnight.

Using Eco mode for HW increases efficiency. Takes longer however.

Thanks for the reply. Do you mean the Eco mode under the heating settings? That’s only one I’ve been able to find. I wasn’t aware it had any affect on the HW settings.

Ah, that’s an interesting suggestion, thanks. We’re currently on Expanded, which is what was set by default, and what seemed to make sense to me. But reading the descriptions again now, I wonder if I hadn’t properly absorbed the difference between that and Active.

Will mull that one over - we’re currently on Cosy Octopus, and using a “charge up and coast” strategy to get over the peak period, which works well (i.e. HP switches off during that period) in general. But when it’s really cold, we don’t make it through the 3 hours anyway before it comes back on, so maybe Active would be a good fit then. Will experiment next time the forecast looks threatening…

1 Like

Do you have a battery? Cozy seems to be aimed for that.
I’m on Tracker. So far so good. No need to worry about peak periods.
Use to be on Go Faster (0130-0630) and ran the ASHP hard then … got an overall CoP of 4. Since being on Tracker this winter and running 24x7 CoP is > 5.

Thanks for that.

Good to know. We’ve had the HP (only) since late October, and have averaged 3.9 since installation. Most of that time has been on Cosy, so running it harder at certain times.

But this very week we have our PV+battery going in, so will be reassessing the various options once that’s all up and running. Will certainly bear this in mind, thanks.

hello Guys,
I have just updated to the new Vaillant app (myVaillant), some 1 week ago, and I noticed some “missing” features, to say the least…

All data “before” the-so-called app upgrade, is not imported into the new app => ??

Additionally, how is it possible to have electricity used AND Enviroment Yield produced, WITHOUT ANY heat generated (botton graph), early Jan24?

I was wondering if it’s the same with you, guys, as well ?

Looks ok on mine. Something definitely wrong there!

That’s because of the update. Any data recorded before the switch to myVaillant is not yet properly split between electrical, yield and heat energy. I had the same in my app and just went back to confirm - and now it’s all there (wasn’t a week ago). I guess it can just take a couple of weeks for the old data to be properly processed on Vaillants end. I switched to myVaillant in the first week of December (pump was installed a week before) and it took until now to properly update in the new app.

1 Like

Tried it setting it to Active rather than Expanded last night/today. The main effect so far is that we don’t seem to have got down to the indoor target temperature within that period. And by that I mean it can be sitting at 19.5 inside, during a setback period with target 18, and still be running pretty hard (i.e. several kW electrical input). I know it can happily work away at a much lower rate, so I don’t really understand what’s going on here.

Is that an indication that the heat curves need to go down a bit when using Active mode?

I see the same behaviour. Active is pure WC with room compensation, but it doesn’t turn zones on/off.
Only if the return flow temperature drops below the circuit(s) flow temperature demand (FTD) will it turn the compressor off. The FTD is driven off the heat curve.

Thanks, will try edging the curves down a notch and see what happens.

Intriguingly, changing the heat curve from 0.6 to 0.5 made no visible/tangible difference whatsoever - it whirred away happily at a perfectly level 1.8kW even when on setback. Does this mean we’re hitting the lower threshold of its performance (and therefore that our unit may be slightly oversized)? Or is there anything else I should try here - just keep edging the heat curves down?

Anyway, will switch back to Expanded for now and revisit playing with the settings once our battery is installed - one day is okay for an experiment, but don’t want it munching through the peak rate electricity like yesterday!

Even the relatively decent level of info from myVaillant is feeling a bit “over hand tied behind my back” now, so ever more tempted by getting some proper monitoring going…