Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Using CTs with three phases

Tags: #<Tag:0x00007f1be1cd4408> #<Tag:0x00007f1be1cd4340> #<Tag:0x00007f1be1cd4278>

So you are telling me that the most accurate way would be with 3 emonTx’s each with two CT’s connected, one to the mains L1, and one to the PV’s L1, and you want me to put the AC adapter of each on the same phase as well? I can see that it makes it the most accurate, but I also have to have an electrician to make me some outputs for the other phases for the AC adapters. Currently I one have one phase where the emonTx’s are installed. But if that’s what it takes, I guess I might consider it, as I have other small project for the electrician anyway, such as to make space for the CT’s to mount better :slight_smile:

Another quick question… I have put one of my CT’s the wrong way up, so that it reads a negative value now, is it possible to fix that in the feeds? like multiply with -1 ?
I tried it, but it looks like it doesn’t work, or maybe I’m doing something wrong :slight_smile:

/Heino

That unfortunately is often the case, but since you’re at the dist box it is often quite a simple job (for an electrician). Since the ring mains are usually well “ring” they can often take a tail out of the circuit breaker re-route it to a socket mounted next to the dist board and just add a short bit of cable from the socket to the breaker to complete the ring again and that’s it without having a new breaker fitted.

Yes you can do exactly that, either in emonhub in the scales settings or in emonmcs, the former will correct the data before distributing it, the latter will only fix it in that location, so if you have 2 emoncms, you will need to do both or once in emonhub.

@pb66 I doubt that Heino has a “ring main”, as he is in Denmark. He will almost certainly have radial final sub-circuits.

Let us go back to why the 3-phase sketch is not the best. It is simply because there is only one actual measurement of voltage, the voltage for the other two phases is derived from the voltage of the first phase. If all three voltages are identical in amplitude, that is not a problem, but in practice, they will not be. So although the current is measured accurately, the power may be wrong because we can only hope that the voltage will be the same across all three phases.

If you use one emonTx on one phase only (with the standard single-phase sketch), it knows the voltage of that phase, so it can calculate all four powers accurately.

And just to clarify, if you use the wrong sketch on the wrong system, the voltage and current can be around 120° apart and then you’ll get totally wrong powers, you’ll read about half the correct value when the voltage and current are on different phases.

That is one of the clearest explanations of that phenomenon I’ve read!

1 Like

My 3-phase “Mk2” PCB will allow real power to be properly measured in a three phase environment. It monitors the three separate voltage sources and uses three CTs, one per phase. The resulting data can be transmitted by RF just as for the emonTx.
http://mk2pvrouter.co.uk/61101.html

1 Like

Hi Robin,
Sadly I have already ordered some more emonTX modules, and I am eagerly awaiting them :slight_smile:
But your PCB also looks nice. I guess I will not need the three AC/AC PSU’s as with the emonTX setup?
I would still need two PCB’s, right? One for my 3 phase mains, and one for the 3 phase PV ?

Right now I have the CT clamps on the 3 phase mains, and I am able to see when the power is exported (on a sunny day), as it shows me a negative current, so I have enjoyed that the last few days.
I guess the pulse counter isn’t much good at I have noticed that my meter (Kamstrup) also blinks as I export power…

Yes, with all the hardware you already have, I realised that I was probably too late :frowning:

My 3-phase board supports continuous V * I measurements on 3 phases at a single location. To monitor in this way at two different locations, you would therefore two of these boards. No extra adapters are required; AC waveforms for monitoring the voltages on the three phases are generated on the PCB.

In many parts of the world, grid-connected customers are charged when their surplus energy is exported. Could that explain why your utility meter is blinking? In the UK, exported energy does not incur a cost penalty.

My Mk2 PV Router design will divert any surplus energy to a suitable on-site load.

Hi Robin

Just for @Beardmann’s info, if this does turn out to be the case, there is an emonTx sketch for driving a Mk2 PV Router written by Robin, on the archived forum. To that you could just add Robins diverter hardware on one or all 3 phases.

Although not helpful here as it will undoubtedly be some months before it is anywhere near ready, but we are just starting to design a new STM32 based monitor that can also cater for 3 phase and up to 15 or 18 (or more?) CT’s (using add-on slave boards to keep the base model price down) that will hopefully also include the diverter logic and output for driving diverter HW as standard, nothing is set in stone yet but the STM has plenty of horsepower and the sampling speeds are phenomenal, ideal for driving diverter HW.

In the UK, 3-phase power is charged on the basis of net consumption where the flows of energy in all three phases are summed together. So if there is some export on one phase, a similar amount of power can be taken from the other two phases without any charges being encountered. To accurately divert surplus energy in such an environment, you need a single controller (processor) that knows about all of the phases.

In other countries such as Finland, each phase is recorded separately. In such locations, three separate diverters would be fine. Alternatively, a single controller with bespoke software to mimic three independent diverters would work just as well.

Oh joy, I have now received a package with my new emonTx. So right now I have three of them, but I will start using two of them for now, and I am aware that the perfect setup would be three of them, one for each phase, and with the AC PSU connected on each phase. But for now I only have access to one phase for the PSUs.
But I have been using just one emonTx to log my mains phases. And it has been showing negative values as the PVs get into action… And I think I need a bit of guidance on how to setup this in the feeds…
I have connected the 2nd emonTx and changed the ID, so it does not clash with the exising one. I have connected this one to the three phases from my PV, and it shows positive values.
I have then created a solar Feed which is the three phases added up… so far so good…
I now have a nice yellow graph on my Solar App… yet I think something is wrong with the export values, as it right now shows: Use now: 900W, Solar: 1600W, and Exporting: 3000W which cannot be correct? I would think that export is Solar minut Use ?
I think this is because of the negative values on the “use” Feed as the PVs are supplying more power than I currently use…
But how to fix it?

Just an update, and I think I have figured it out…
My mains and PV phases seen to join in a relay, and I put my main CTs on as close to where the mains enters my house… so that’s why I get the negative values when exporting power…
I have now, with some hassle managed to set the CTs just before the phases join in the relay.
So I have 3 CTs before they join, and 3 on the PVs just as they enter the relay.
The figures looks a bit more realistic now :slight_smile:

One thought… would it be possible to buy smaller CTs than the ones delivered with the emonTx?
I have already broken one trying to force it in between wires :wink:

Yet another update :slight_smile:
How accurate are the current clamps?
I seem to be missing 3-400W somewhere… My inverter is telling me more than the clamps are.
And this is just at about 1200W showing on the inverter which translats to about 800W on the 3 clamps combined…
Is there an adjustment that I need to do somewhere?

The current transformer error is only one contributor to the total error. Typically, most users see an overall accuracy of around 1%. But if you are unlucky and all the component tolerances add up the wrong way, you can have a very much larger error.
There is a calibration procedure for the emonTx, you will find it in the ‘Learn’ section: https://learn.openenergymonitor.org/electricity-monitoring/ctac/calibration

There are smaller current transformers available, but very few that are both split core (meaning you do not need to disconnect wires to install them) and suitable for use with the emonTx. If you can legally and safely disconnect wires, then it might be possible to find a smaller ring-core c.t. that will be suitable for you.

Sorry to dig up this old war wound again, but I finally got a visit from my electrician, and I made him install 3 plugs, one for each phase, where I have plugged the AC PSU which powers the emonpi, the two others each power an emontx.
So phase one powers the emonpi and it has connected two CT clamps, one from “use” power phase 1, and one from PV phase 1.
The two emontx’s are setup in a similar way, so they both have two CT clamps, and one phase each from both the usage power, and the PVs.
So everything should be nice an dandy now, right? :wink:
Well… not quite… :wink:
For some reason the numbers I get form the clamps seems to be way off… and I have tried to reconnect them and made sure they are closed all the way etc…
I do have some of the clamps on that “wrong way” so it shows a negative value, but I fix that by multiplying with -1…
One thing I do’t understand is that when I look at my inputs page, I can see a value of about 250 for the first phase (I call it brown phase because of the cables…), but I then add all the phases up into “use” and in that window it shows only 86’ish as the value, which I do not understand at all… ?
I have adde a new screenshots to show what’s going on…

As you can see, I first publish the “Brown Phase”… I then add the Gray and the Black phases (they are both showing a negative value), so I add the two negative values together, then multiply with -1, then add the Brown phase, and publish it as “use”…
But somehow the values doesn’t make sense to me…
To me it looks like the Brown Phase is showing a lower value, and it is not added to the two other phases…

This might just be me not understanding how the syntax works? :slight_smile:

I think you are correct there :cry:
With some exceptions, the result of an operation is passed down the list to the next, and used as the input to that. What you have done is:

((Brown + Grey + Black ) × -1 ) + Brown = -(Grey + Black)

What you want is:

Log to feed “Brown”
× -1
+input Grey
+input Black
× -1
Log to Feed “Use”

…etc.

The first ×-1 gives you -Brown, now all 3 will be the same and all negative (and wrong). The second ×-1 will make the sum positive again.

Well… it still looks funny…

If you add up the values in this example, they should add up to 600, but use it only Gray and Black added together?

But if I look at the Feed of “use” it looks correct… (it has changed a bit in this example…)

Is that now not what you want?

Well yes, I just think it is a bit confusing that it does not add up the values in the “Input view”…
Granted it looks much better now :slight_smile:

Now I just have to figure out why the PV phases show about 100 Watts right now when it’s dark, and the inverter has shutdown? Is that a normal reading with the CT clamps?
Actually two of the PV phases shows about 100 Watt each, the last one shows -10…
100 Watts of inaccuracy seems a bit much to me, but maybe it’s just me?

There was a discussion a while ago about whether it was better to add inputs or feeds… I can’t find it just at the moment, but (link below) the advice at the time was to add feeds, not inputs…

Based on that discussion, this is how my 3-phase is configured:

And here’s the details of the PowerL3 processes:

I’ll see if I can dig out the discussion on why it was considered better. If I find it, I’ll update this post.
Found it…

Yes, I guess there are two ways to doing it…

I have just tried to add the “import_kwh” Feed which the “My Solar” App wants…
So I created a Virtual real time feed where I added “use_kwh” as a Source Feed, and subtracted “solar_kwh”…
I hope this is the correct way to calculate the “import_kwh” value? It’s showing a negative value as I have produced more than I used today :wink:

Well :slight_smile: . That didn’t go well at all… it caused the “My Solar” app to freeze up, so I have to delete it… so I will have to figure out another way to do it…

…infact I think I just fouled up the whole system somehow… I was trying to do the import_kwh as described above… via an Virtual Feed… I think I did a +feed use_kwh and -feed solar_kwh, but I was unable to see the Feed from the App, so I added a “+Source Feed” thinking it would add a Feed that I was able to use… yet it hanged the whole system… so the web is 99% dead, just hanging now…
I am able to SSH into the system… a top reveals an apache process using 99% as soon as I try to access the web…
I’ll try a reboot now, but I don’t expect it to fix this issue…

Yep… didn’t fix it :frowning: . Is there a way to delete a Virtual Feed from the command line?
I realise this is way out of the original subject, and I’m sorry for that… but also a but desperate…

Phew :slight_smile: Managed to find some information as to how to access the mysql database and delete the bad feed I have created… after a reboot, we are back to normal again :slight_smile: I think this is enough action for tonight :slight_smile: