Community
OpenEnergyMonitor

Community

Update from 9.9.5 to 10.1.6 some errors

Hello

I just update my emoncms from V9.9.5 to 10.1.6. Inputs are working and also showing all values are ok.

But just when i access the “admin” page i got the follow errors

dir restriction in effect. File(/usr/sbin/mosquitto) is not within the allowed path(s): (/var/www/vhosts/mydomain.ch/:/tmp/) in /var/www/vhosts/mydomain.ch/xxx.mydomain.ch/Modules/admin/admin_model.php on line 284

Undefined index: total in /var/www/vhosts/mydomain.ch/xxx.mydomain.ch/Modules/admin/admin_main_view.php on line 303

Notice : Undefined index: free in /var/www/vhosts/mydomain.ch/xxx.mydomain.ch/Modules/admin/admin_main_view.php on line 305

And follow entry in the Update-Log and Emoncms-Log

Warning : file_exists(): open_basedir restriction in effect. File(/opt/openenergymonitor/EmonScripts) is not within the allowed path(s): (/var/www/vhosts/mydomain.ch/:/tmp/) in /var/www/vhosts/mydomain.ch/xxx.mydomain.ch/Modules/admin/admin_controller.php on line 42

I have found some issue:
In the settings.php are the follow default path are defind
//Suggested installation path for emonpi and EmonScripts repository:
$openenergymonitor_dir = “/opt/openenergymonitor”;

But this path are not exists! Where can i download the data for this path?

May somebody has me a hint. Thx

Best Regards
Gregor

How did you perform the update? What is it installed on?

I just override the files with the new version. also override the module dashboard, graph and groupe

Ok so the normal update script does do other things especially regarding services.

Can you tell me the output from the directory Modules under your emoncms folder please?

e.g.

ls -la /var/www/emoncms/Modules/

grafik

I think your issue is that you are on a shared hosting environment so some of the info the Admin page pulls in, is not available or restricted. These are all fairly recent additions to the information available on the admin page.

@emrys - could you look at this? Perhaps some checks that catch the errors?

@TrystanLea - I said this before, but I think there needs to be something that tells EmonCMS what type of system it is installed on so things like this can be filtered out. I can think of 3 states initially - pi, unix-self, unix-shared which could go in as a setting perhaps.

[edit]
I have raised a GitHub Issue

@gkobler, could you post a screenshot of the page with errors please?


I found an other error: Just open the users

With Version 9.9.5, i have no problems!

Yes, it is called improvements!

So the Emoncms log file error can be solved with a change to this setting in settings.php

$log_location = "/var/log/emoncms";

to a location the webserver can write to (I think).

the correct settings on my server are:

$log_location = "/var/www/vhosts/mydomain.ch/mysubdomain.mydomain.ch/var/log/emoncms";

otherwise i got may errors on the page!

Ok great.

Yes they will take a bit of time to fix but they will not affect the software operating (I think).

1 Like

Thanks @gkobler @borpin noted the issue created in the emoncms repo.

Hello

Is there are a newer version, where solve the issues? Thanks

Gregor

Have you pulled in the latest version?

1 Like

Yes if you could try the latest version @gkobler that would be great. Im not sure that it will solve all the issues but if you could copy here all the errors that you see again for the latest version, including line numbers etc that would be really useful.

Please download/use the emoncms master branch, so that you have all the latest changes.

Hello @TrystanLea, i have downloaded the version 10.1.13 and was a little confused of the settings files. Should i setup “settings.ini” or “settings.php”. But in the “settings.php” there are a remarke “Do not edit”!!

I tried to setup both files, but when i download all the files to my hoster, and call the url i got an empty page! No errors are appears or something.

Do you mean you have updated to this version (as per the thread title) or that you have started afresh with that version - it does make a difference.

@borpin I have download it to my PC, then modified the settings and deleted all the files instead of the collected data at my webhoster. Then i upload the new files to my webhoster. I hope my step are correct, or are there an other easyer way to update at my webhoster?

Ok, yes shared hosting environments are a pain.

For settings, use the pair of ini files rather than php files. Leave the default-settings ini file alone and copy the example-settings ini file to settings.ini and modify the settings you need to change in that.

HTH