Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Update emon evse wifi firmware to 3.x - lost connectivity

Tags: #<Tag:0x00007f68225c7470> #<Tag:0x00007f68225c7240> #<Tag:0x00007f68225c7128> #<Tag:0x00007f68225c6f98>

Fear I was a bit too gready - sorry

Update my emon evse wifi module to 2.9.1.
Worked fine.
Tried 3.1(?) - restart failed - connectivity lost.

Do I need to go back to factory settings through hardware reset or is there another method?
Do I need to open-up the unit before I can push the GPIO0 hardware button or is there a workaround for this?

I stand to be corrected but I think the 3.x versions are for the newer ESP32 module, not the older one.

Thanx for your input!
You could very well be right.
This is a >= June 2020 unit though.

To factory reset or not to factory reset: that’s the question.

Brgds.

Antoine

Hello @Antoine_Maartens, @glyn.hudson should be able to help with this.

Hi,

Yes, @greentangerine is correct. If you were previously running successfully V2.9.1 this means you have an ESP8266 V2 WiFi module. This module can only run V2.x firmware.

The newer ESP32 V3 modules can run firmware V3.x .

The good news is that in terms of features V2.9.1 is almost identical to V3.3.2, we’ve managed to back port most new features to the older hardware.

That bad news is that to restore your module you will need to manually upload V2.9.1 firmware using a USB to UART cable and our emonUpload or esptool. See instructions on the V2 readme for how to upload firmware via serial: https://github.com/OpenEVSE/ESP8266_WiFi_v2.x#upload-pre-compiled-firmware

Thanx for your input Glyn and sorry to be an over-eager nuissance.
It is what it is.
The factory reset would not do the trick?