Update Crashes PHP, on RaspberryPi reboot no recovery path

Hi, New here, from Brisbane Australia with very limited Linux skills, about 15 years out of date.
Just logged onto EMONCMS, and triggered one of two update buttons in administration. Update failed with message. A reboot did not recover access, but machine shows healthy LCD data, just no web access. I might just be unlucky, or update process may have gremlin?

settings.php file error
settings.php config file has new settings for this version. Copy default.settings.php to settings.php and modify the later.
To fix, check that the settings are set in or try re-creating your settings.php file from default.settings.php template

Just downloading virtual box then Ubuntu so I can read SD card from device and copy/make changes proposed. Is their any end user easier method to restore service and keep 11 months data? The correction method should not destroy data. The Raspberry PI runs May 16 emonPI software, no update admin process seems to update this SW, I moved to low write SW V9.?? a few months ago and this has updated at least once via manual action, expected similar seamless update today, not to be!.


Hi Peter,

the reason is that the settings.php file was updated with last emonCMS update. Maybe you changed it manually so the automatic update broke? To fix it please see this post: Upgrade emonpi created a brick: settings.php error - #2 by glyn.hudson

Hi @Quoll, is the “settings.php file error” shown in place of the usual emoncms webpages and the only noticeable symptom?

That warning is just to tell you that the emoncms update included a revision that effects the settings.php file and that you need to revise your settings.php so that it includes the new revisions and your current user settings. The updater doesn’t edit your existing settings.php nor does it force an overwrite to the new default file, you must manually create a new settings file and add your password etc (or determine the revisions and update your existing file, I usually opt for the latter).

Have you tried ssh’ing to the emonPi to edit from the command line?

user: pi
password: emonpi2016

This is quite a common concern and if it is only this your data should be fine.

Simsala & Paul, thanks for your help.

I restored the settings.php files using Ubuntu and reassembled the emonPi. All works with a two hour data loss only. I have not tried SSH in, as I rebuilt SD card for one update and use GUI only. I will explore more elegant maintenance methods you have suggested.


1 Like