Undervoltage and smd fuse on emonpi 1.6


I use emonpi v1.6 for almost 3 years now but for the last 6 months I had the well known undervoltage message in the raspberry pi (RPI3+). Initially I thought it’s the PSU so I tested different PSU’s but the problem persisted.

Today I decided to have a closer look and get some measurements. I used a bench supply to pass voltage behind the USB port to the one end of the SMD fuse. I saw again the same problem which didn’t make any sense since I used a bench supply that can provide up to 10A of current and has stabilized voltage output. Therefore I tried to supply voltage at the other side of the fuse and to my big surprise the undervoltage message and the yellow symbol disappeared. I desoldered the fuse and took a resistance measurement which gave me 2.5 Ohms which is way too big for a fuse. I had a broken RPI3 on my inventory which I used to get the onboard fuse and solder it on the emonpi board. The problem is solved now. No undervoltage message either with the bench supply or using the Chinese 5V/2A PSU.

I think emonPI isn’t a supported hardware anymore but I do this post mostly for users who already have a electricity monitoring system based on EmonPI and they face the same issue.

1 Like