Uncaught TypeError: Cannot read property 'push' of undefined

Hi there!

I’m just re-flash a new SD with the last image 30Oct2018.
I try to show in a “Graph” some feeds, but appear the error:
" Uncaught TypeError: Cannot read property ‘push’ of undefined "
This occurs when I click on any item of page of graph
And don’t show any feed that I select…

what can I do?

I have sended some inputs from another raspberry(node0) and from Emonpi (node EmonPi) itself, and added this inputs as feeds …any feed can be showed and causes the error…

the feeds are correctly been registered in the database …at least, in the visualization section it can be showed…


We’re having trouble replicating this here. We have added improved logging of JavaScript errors to give a line number in the latest update (v9.9.5). Would you mind running emonpi update to pull in the latest and see if the error appears again, hopefully this time with a line number.

Hi @Tristan!

I update EmonPi and efectively shows more info …

I also have an issue, since the last EmonPi update, that only update inputs from remote nodes(another raspberry that sends data with "curls -s … "
The values of the local node(Node EmonPi), before were readed with value 0 (nothing connected yet to CT…)but readed. Now there aren’t read…

can the two issues be related?


Node emonPi problem solved !
reboot whole system and ok.

Hello @Xavi_Gorriz could you run update once again and check the error, it should now show the file that the error is associated with.

Has it worked since you started with a new image? If not, the API key will be different.

Hi Mr. TristanLea!!

I “update EmonPi” and after “update & Check” …:

Update database

Database is up to date - Nothing to do

and finally reboot.

and the message that appear on click any item is…

Hi @Borpin
the issue of no update local inputs but update the remotes, was easily solved…

I don’t completly configurated the system yet, nodes, some hardware, dashboards, etc…but also I have another raspberry that’s sending values to emoncms.org and now I want to re-direct them to EmonPi …

I think the first step is send inputs, add them as feeds and work with this feeds…
With first image 2015 was work with some errors …but update all inputs.

Image 30Oct2018 worked ok (at least what I was testing), but when I update EmonPi and reboot, the local inputs don’t update, but yes the remote nodes ( values sended by other raspberry…)

It was be rebooted another time and all was goes ok(except the actual issue of Uncaught TypeError: Cannot read property ‘push’ of undefined "

Hello @TrystanLea !!

I see some interesting thing about this issue …
I try from diferent browsers Opera, Chrome, and Explorer … all with, more or less, the same result ( Explorer with more faults)
but… I try from Chrome of an Android phone … and with this it works ok !!!

this can indicate that the problem is in my browsers…??