Unable to find Solar Feed to CT

Hi all,
well i have had the system running for a couple of days and i am happy (and impressed) with it, I got it running with only one CT clip, but as i have solar I went out and bought another CT clamp which arrived today, time for another play.

Unfortunately not being very electrical minded i am not able to obtain any data from the second CT clamp to pull in Solar data. I have changed the CT’s over so the one that was working on slot 1 was changed to the one that i could not get to work in Slot 2 I had hoped that this would have showed me that the second CT clip was faulty, it wasn’t, when the one that i could not get to work was put to the house cable it worked, so not the CT’s clamps.

I have also removed all inputs and processes and recreated them, whilst doing this and following the instructions i noticed that there are two setups one for houses that can see separated solar and one where its difficult to separate the solar from grid, neither worked.

I am definitely generating and exporting Solar as i am recording import and export (export is only a negative flow though), i can see that from the feeds and the apps.

As you can see i am logging some info and am exporting, so my thinking was as follows:
1: I have the CT clip on the wrong wire
2: I have a configuration error on the EmonTX or PI.

1: I have tried the CT clip on every wire that seems to make sense with not output

The blue is the AC coming into the house from the inverter, the yellow is the same cable coming out of the isolater and into the solar trip switch. Coming out of that i see two large cables “1” & “2”, i have been assuming that these are the cables that i would want to monitor with the CT clamp that goes into port 2 of the emontx.

2, Well to be honest if it is an issue in the emontx then i am stuck, but here is a log file just in case
emonhub.txt (834.7 KB)

I am quite happy to admit that electrics baffle me (though i thought i should be able to work out where to put the clamp), maybe not, so any suggestions or recommendations would be very much appreciated.


Forgot to add inputs

Are you feeding your solar c.t. into your emonPi or emonTx? Did you power down and power up again after plugging the c.t. in? You must, because the c.t. is only detected at power-up. Resetting the Pi part of the emonPi is not enough.

Unfortunately, you’ve done such a good job covering up the cables with your mark-up that I cannot see the cables themselves. If you had restarted as above to no avail, I suspect you might be putting the c.t. on a twin-core cable rather than a single core. Here are two pictures. You can see the two-core cable is flattened, whereas the single core is completely round. C.Ts work on the magnetic field around the cable - with a 2-core, the fields cancel - simple when you know!

As for the placement - OK is anywhere between the inverter and where the PV feed joins the rest of the house wiring, and that looks to be at what we call “Henley Blocks” (though they are probably not made by Henley any more, one is the white box tipped over 15° to the left near the bottom of the picture, with two round cables into the top, and one into the bottom; and the other is the black box immediately on its left. There are two more, one under your red “2” and another immediately below it). And the c.t. can be either on the line or neutral, if it’s on the neutral it needs to face the opposite direction. I think “1” or “2” are the correct cables, but I can’t be absolutely sure.

BTW, I get nervous every time people mention “clamp” and c.t’s. The c.t. core is very brittle, and if you try to clamp or wedge it on the cable, you risk snapping the core, and that means a new c.t.

1 Like

thank you for your assistance, it is very much appreciated, however i now have it working, i am sure its not totally unexpected, but it was user error :frowning:

I think the clue that you provided was "powering down and powering up the emontx unit each time i made a change, i was not doing that so i was never getting an imput.

I did try again on each cable powering off between changing the CT clamp, but that still didnt work, then i decided to go back to basics and try to at least get the CT clamp reading something by putting it onto the house import cable that already has a working clamp on it, still nothing :frowning: next i thought it might be the emontx port 2 having a problem so i powered down the device and moved the cable to CT Port 3, powered back up again and bingo, it was working.

Powered it back down and put the CT clamp on one of the original large cables (previously marked 1 or 2) and plugged the cable back into port 2, everything worked fine.

It was my failure to understand that i needed to power the emontx down each time i made a change, and then remove and reinsert the cable. Often it is the simplest of things that trip us up.

Many thanks for your assistance.

Mine isn’t showing any solar reading either, do you think it’s the 6" of snow on the solar panels!!


Nah, it’s the Marcolins stealing all the electricity to keep themselves warm. :grinning:

[Marcolins are the electrical cousins of Gremlins.]

1 Like

You shouldn’t need to unplug and plug in the c.t, it’s the power-down — power-up sequence that enables the input in the software. (The same goes for the a.c. adapter. We do it so that, for the c.t’s, you don’t get a stream of low, false values that are noise pickup, and for the voltage so that it can assume a nominal 230 V and give you apparent power if there’s no a.c. adapter.)

You’re not the first to get tripped up by this, it’s actually in the FAQ’s.

I did read the FAQ, i obviously did not read them sufficiently enough, will go and have another read through, but i am happy.

I really wanted to get some data before the house battery system arrives later in the year, that i suspect will be another issue, but i may just ignore it and treat it as Solar that just lasts longer :slight_smile: