Ubuntu 18.04 server on beaglebone - dashboard not working

Hi all,

I just installed the latest emoncms version on my beaglebone black running 18.04 LTS.
I have difficulties getting the dashboards to work. After installing the modules (which all goes perfectly) and updating the database I still cannot get the dashboards to work. On the dashboard page, it just says ‘found 0 entries’. No option to create a new dashboards or anything.

I have an other running version of emoncms on my laptop and I did exactly the same steps to install emoncms. On that version dashboards do work.

Anybody can help me? What am I missing?

Thanks in advance

I’m afraid I’m not familiar with BBB or Ubuntu. Is your laptop also 18.04 LTS? Is your laptop running the very latest emoncms too?

Could this issue raised on the emoncms repo be related?

If your laptop is running a emoncms/dashboard version a few commits behind the BBB and you are ok with git commands it might be worth rollng back emoncms/dashboard on the BBB to see if that helps.

@Sybren_Vanheeswyck : to create a new dashboard, just follow the route /dashboard/create.json
it will return a json output with the dashboard id as a proof of success
you just have to refresh the dashboard list by following the route /dashboard/list
The dashboard button is actually just missing…
Everything should be fine with Ubuntu 18 :slight_smile:

Hi guys,

Thanks for you help and time.
I seem to have fixed it. The BBB was running dashboard V2.0.2. My laptop was running V2.0.1.
Upon downgrading the dashboard everything works as it should now!

Kind regards,


@Gwil @TrystanLea - this probably need investigating and fixing.

@glyn.hudson closed the git issue yesterday so maybe it’s already fixed ???

1 Like

Sorry, didn’t check.

@Sybren_Vanheeswyck, would you be willing to try and pull the latest dashboard from git?

@glyn.hudson, could the version number be bumped & tagged please.

No, it’s only because I added a link back to this forum thread in that issue that I got notification of it being closed. I would have expected a confirmation of the fix somewhere, perhaps here as there was a link.

1 Like

Yes, ‘New’ button has been added

This has been included in V2.0.2 Release V2.0.2 · emoncms/dashboard · GitHub

I don’t think so @glyn.hudson.

The merge for 2.0.2 happened on the 14th, and the fix to the above issue was merged to master 2 days ago. The ‘release’ is now 10 commits behind master, the tag and the version number do not align (as the version number refers to a tag ‘release’).

This needs a stable branch to work properly (broken record) or you use a dev branch, and when that is merged to master the version file is updated and a patch/minor release is created. This is actually a better solution than a stable branch.
Apologies there is a stable branch - my bad. There does need to be a new release with this fix though.

1 Like



I set up this exact scenario on a spare BBB.
When I updated the Dashboard module, I had to use -b master to get it to work correctly.
(when I tried -b stable there was no change. i.e. it didn’t resolve the issue.
Does that sound like the same issue you mentioned above?

Not really; I’d made a mistake and missed there was a stable branch. The fix is therefore in master (as you found) but not in stable (tagged 2.0.2).

OK. Thanks for the explanation.

The latest changes have been merged into stable and a new release V2.0.3 has been made to include all changes plus some new minor fixes: Release V2.0.3 · emoncms/dashboard · GitHub

1 Like