Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Stuck Contact

Over the 1 year I’ve been using OpenEVSE, I’ve now got the “Stuck Contact” error total of 5 times. Latest one this morning. Should I be worried or replace some component? Is something faulty? Can I check something? Why does it occur so seldom/randomly?

I haven’t identified any specific common reason why this occurs, I just notice it in the morning when car has charged few hours at night (via Demandshaper). Nothing common in weather conditions for example, now it is -15C and first time it has occurred in such cold weather.

I can just restart the device via web UI to work around the issue. Firmware 5.1.0.EU, wifi firmware 2.9.1.

I’ve read this but it doesn’t exactly apply as my issue always goes away after restart: OpenEVSE boots and displays "Error Stuck Relay" : Support.

Hello @jpalo I’ve sent a message to @glyn.hudson to notify him about your post, hopefully he can help.

Hi Palo,

Sorry to hear your having issues. The Stuck Contact error is as the name suggests the contactor sticking closed after the charging session has finished. This is a safety issue since it means the pins in the EV charging plug could still be live when the plug is unplugged from the EV.

How often does the issue occur? Do you see the error message on the LCD display? The first thing to establish is the contactor actually sticking. If you are competent to do so safely next time the errors occurs use a multimeter to measure if the EV socket pins are still live.

It’s interesting you mention that restarting the web UI clears the error. If the contactor was actually stuck I would have thought the error would have persisted.

We would be happy to send you a replacement contactor if required.

It has occurred 5 times now over 1 year, so not too often. LCD goes red and shows that same error. I have equipment to do the measurement safely, so should I unplug charging plug from car and measure (which) pins from the plug? Haven’t looked at the pin schema yet.

Now I’m not saying it is necessarily related, but first time it occurred immediately the following overnight charging after I updated the Demandshaper module of Emoncms to the latest version in September or so. It occurred 2-3 nights after I reverted back to older version of DS. I haven’t been able to 100% (well, not even 50%) link the problem to the new DS version after bthat and the issue has occurred now twice even with the older version.

I will monitor the situation, no rush for the replacement contactor yet.

You will need to measure between L1 and N

That’s strange, but the OpenEVSE safety functions are monitored by the OpenEVSE controller which is totally independant from DemandShaper. Are you logging all metrics from the EVSE to Emoncms e.g current, pilot, temperaure? If not, it would be a good idea to do this, since looking at the trends overtime can help identify issues.

It would be a good idea to remove the front cover of the unit and inspect the wiring just to make sure all is good physically inside the unit.

1 Like

Keep running into this more and more, it has now occurred few times within few weeks. Haven’t yet opened the case and ensured nothing has loosened, so before doing that it makes no point in posting here but will do it anyway just to include this video as you seemed to wonder how it was able to get fixed just by a restart. Also realized my multimeter only goes up to 10A, so cannot see if pins are live.

Here’s a video showing how the restart immediately fixes the issue. Car was plugged in at the time of the video.

I’ve just had this error today for the first time.

Did you get your issue resolved and if so, how?

No, I still get it 1-2 times per month.