Sontex Heat Meter "Conf Error"

Our power was out earlier today for a couple of minutes while I updated Victron inverters and now my Sontex heat meter is showing “Conf Error” and reporting incorrect flow and kW.

Has anyone seen this or know how to resolve it?

Externally powered meter?

Dead backup battery plus power out corrupts eeprom in meter.

Try pulling the faceplate off, letting it sit for a minute or five, them reattaching.

Try this and the power off for 5 mins then reassembling and power back on.

Failing that you can sometimes bring them back to life by reading out the settings then writing the settings back in again to bring them meter into a happy state.

Or moving the faceplate from one back body to another and back again.

Chris at DMS the expert in rejuvenation on these!

It happened a few months ago, but power cycling fixed it, not this time though.

The backup battery is li-ion and should stay charged, shouldn’t it? Let me try powering down for 5min with the faceplate removed.

How would you do this?

Hmm. Where are the two EEPROM’s in the face-plate or the rear portion? I do have another 531 here, but I’d be worried that settings get mixed up if the EEPROM is in the rear portion.

Chris supplied this one (via our ASHP installer) and I’ve spoken to him before, so I’ll have to give him a call if I have no luck.


Backup battery is not rechargeable. Lithium but a long life memory backup type chemistry not lion.

Need sontex software and an optical head to read out settings and write them back in.

It’s been a while (4 years) since I had to rejuvenate one sorry. Certainly swapping the faceplate back and forth is often enough from memory though.

And that backup battery is toast. Have a look at manuals but it’s days/weeks not years it lasts on these if unpowered but measuring

Strange thing is its never been unpowerd for more than an hour and the last time power was only off for few mins. I think the battey is soledered in, else qould replace.

No risk of mixng settings switching faceplate with other unit? Depends where eeprom is etc i guess


  • The on-board battery is still good.
  • The Battery on the face plate still had the plastic tab in place, so wasn’t operational.
  • I tried multiple things, but can’t get passed the “conf error”. The heat meter is functional, but the flow rate is incorrect, seems it’s lost its setup and also kWh reading.

Going to send it back to DMS for re-programming, not sure what happens with RHI but will cross that bridge later.


The faceplate is perhaps the “thinking” part in that case!

(baseplate being the interfacing part only?)

Let us know what you find!

Yeah, or at least the memory bit. The battery in the face-plate is to keep config and kWh I think, whereas the battery in the base is for taking readings (at lower frequency) when there is no mains power.

It’s probably supposed to have a smooth transition from mains<->battery power when there is a power cut, but for some reason that didn’t happen in my case, on one specific occasion. And, because of this, along with the fact that the face-plate backup battery wasn’t connected, meant it lost readings and config. That’s my assumption anyway,