SOLVED: Brand new emonPi, no graphs after 24h

I bought an assembled emonPi and followed the setup guide carefully. I’m a pretty generic setup with two thermometers and a pulse sensor (In have not plugged in an AC reference, not sure I need it as I don’t generate anything (sadly). All inputs are working and recording and the android app shows lovely data being recorded, as do the web apps on the emon pages.

But.

The emon graphs and dashboard are just blank white pages. e.g. I click the “eye” for a feed and get the black header bar and a blank white page below.

If I try to view or edit a dashboard I get the same.

If I go to “Visualisation” I can look at different views of my data.

I am pretty geeky in that I can use SSH and console but really wanted this to work out of the box. Is there an easy solution?

What’s an ‘emon’?
emonpi, emonbase, emontx…

Paul

Guess you send data to emoncms.org ?
Did you setup feeds ? setup the graphs in the dashboards ??

There are quite some steps you need/can do to get the results you want.

Maybe elaborate some more so we understand what you use, what you did etc … from there we might help you some more

Sorry, it is emonPi.

I have not yet set up data to point to emoncms.org.

I have followed the setup to this page: http://guide.openenergymonitor.org/setup/local/

It says

To view the feed data click the Eye Icon
This will open Data Viewer
Multiple feeds can be overlayed on the same graph by checking the boxes on the right hand side
To view daily data see Emoncms > Daily KWh.
Note: no data will be visible immediately. Wait a few hours to build up some data before trying to view a feed.

I click the eye and then just get the blank page. e.g. 192.168.0.154/emoncms/graph/3

I am not sure what the “Emoncms > Daily KWh” instruction is.

I wanted to get it working locally before pushing things out.

I have tried multiple browsers and computers. If I click Setup > Dashboards then click the pencil in a box (192.168.0.154/emoncms/dashboard/edit?id=2) I get the same blank page:

were you able to do all the steps before this one with the result shown ?

Basically you’re at the last step but it depends on all the ones before

Data needs to be channeled to some parts before you can use the graphical module.

inputs → feeds → stored as phpfina etc etc

Yes. I followed them pretty carefully. I also double checked before posting
here. At each step my screen looks exactly like the ones in the tutorial.

The apps work and my android see the data nicely. Also the visualisations
work so I know the data is present and recording.

I’m happy to start over with a fresh install if that’s what’s needed, but
don’t really want to unscrew the ends and pull and reflash the sdcard. Can
I reset through console somehow?

Yes, it’s possible to reset via console. However this should not be needed.

Coul you post some more screen grabs showing your feed page and what happens when you click the little eye icon on a feed. Keep in mind you need data in the graphs to view data, it will take a few min after a feed has been created to have data to view. You should see something like:

Yes, that is what I am NOT seeing :frowning:

As a new user I can only do one image per post so hope I don’t get done for spamming this thread:

Inputs:

Input config

Feeds:

The “My Electric” app to show data is working. I can play around with the visualiser with no issues too.

But the “eye” button in FEEDS always gives me the blank page that I put in the post yesterday.

Hi Thomas, I’ve bumped up your user trust level, you should have no problems uploading images now.

1 Like

Thanks. I looked at the HTML for the graphs. The meaningful html between the toolbar and the footer is this:

        <div id="topspacer"></div>
             <div class = "container-fluid"><div class="row-fluid"><div class="span12">
                </div></div></div>        
    <div style="clear:both; height:60px;"></div>

Not sure if that is helpful?

I am using firefox. I have turned off adblock in case that was causing issues.

Thanks a lot, all the screen grabs you have posted look good. The MyElectric view shows the data is logging correctly. Could you post a screen grab of what you see when you click the eye icon the view a feed directly? The URL should be emoncms/graph/<feedID>

As I say, I get a blank page :neutral_face:. Here is the full window (the url is shortened because I wanted to make the image smaller, but is, in full: http://192.168.0.154/emoncms/graph/3):

Are there any script errors in the browser console?

Not that I can see.

did you by any change install the graph module ?

If you did, did you do point 2 : Add (or change) $feedviewpath = “graph/”; in settings.php

I did not install the graph module. This is an entirely new setup supplied assembled (I thought this would be easier - I usually assemble things myself) and that was not in the setup process as far as I remember.

I have double checked the console and no errors at all.

Should I install the graphing module?

I just noticed in the server administration the following in red:

WriterDaemon is not running, start it at ~/scripts/feedwriter

Is that in any way relevant?