Community
OpenEnergyMonitor

OpenEnergyMonitor Community

[Solved] Blank Graph, Quality at 0% - Feeds working

Tags: #<Tag:0x00007fc9b1a655e0> #<Tag:0x00007fc9b1a65400> #<Tag:0x00007fc9b1a652c0>

Hey there,

just trying to set up my first local emoncms as a temp surveillance on a rasbpi B+, but already ran into a problem lately.

Background: had a test setup with 3 DS18b20 sensors and a wunderground weather input. All feeds setup, working dashboard and graphs. All great.

Then i enhanced it by 4 more ds18b20, final setup, all soldered and ready to go. Added these inputs, updated feeds and dashboard, all working so far. Unfortunately i now can’t get the graph working anymore for some unknown reason. Older test values are still displayed, new feeds show 0% quality. What’s wrong with it??? Can’t really explain… Might be some value saving / access right / sql database issue?

PS: already tried to setup a second installation on another sd card. First input and feed added, same graph error. So the issue must be somewhere else, thought it was just corrupted somehow, since i had to readd some feeds of existing values on the first installation after adding the other sensors :-/

Any hint or tip appreciated, thanks in advance!

Further information: Data is REALTIME / PHPFINA, Input updated every Minute, feed also.

Edit: just checked one feed online. Same behaviour. No clue :frowning:

Edit 2: Finally solved it. Found out that the time and date was wrong, NTP was not working correctly via my wifi dongle.
Workaround can be found here.

Wonder no one even was able to give a hint that the 0% quality issue could be related to the date/time being wrong.
Thx for your interest.