Solax storage battery inverter not connecting to internet and generally not working

I really need some help with a Solax battery storage / inverter.

We have a new solar pv array on our roof plus Solax storage batteries. We have a Solax inverter x1-fit-5.0-w with a LAN dongle plugged into an ethernet port. The installer is unable to get the inverter operating consistently - it has never worked correctly for 2 days in a row. It has also never connected to the internet.
I am not at all technically minded at all and, to be honest , I should not be the one having to work out the problem, but Solax just say they need to view the inverter online in order to work out what is going on. They eventually said I needed to set up “port forwarding” for the inverter and that my internet service provider could do this. My ISP sent me instructions to follow, but I can’t do what is required as I have to choose the IP address for the inverter (or the dongle?) and I don’t know what the IP address is - there are lots in the list to choose from but most have unidentifiable names. Also, when I disconnect the inverter from the ethernet port, there is no change in the list of connected devices, which suggests to me that either the dongle or the inverter is faulty or needs setting up in some way that I don’t know about.

That’s the current stumbling block.

As for the inverter itself, we have set it to charge between 00:30hrs ans 04:30hrs, as we have cheap electricity between those times. However, we have not experienced it charging automatically between those times on two days in a row. Usually there will be a battery voltage fault - one of IE07 (usually), but something IE02 or IE19. I think it’s IE07 at the point when the battery fills up and maybe that then causes a problem for the next day.

Sometimes it won’t change from “self use” to “manual” - it will switch back automatically to self-use. Even when it does stick on manual, it won’t stay on “forced charge” but will switch itself to “stop charge/discharge”. I tried changing this about 8 times yesterday before it worked.

Sonetimes it charges at less than 5kw, even as low as 1.5kw when it was colder (possibly 0 degrees C). Solax said on the phone to the installer that it may charge/discharge more slowly when cold, but this isn’t in the information that they provide. However it did still seem to discharge at a reasonable speed.

I feel that this could all be sorted out between the installer and Solax on the phone together while the installer is standing in front of the inverter, but it is impossible to get him to do that - he just says Solax needs to look at it over the internet (which also doesn’t work)!

If anyone can give me any helpful guidance I would be most appreciative.
Thanks

Welcome, Paul, to the OEM forum.

I’m afraid I can’t help you personally, but we have a very helpful and together a very knowledgeable community here, so I think there’s a good chance that someone will be able to help you.

The only small suggestion I have is for your question about the IP address of the inverter - it should be either on a label, on the dongle or in the documentation. When you say

presumably you’re looking in your router? That would have been my other suggestion - and the safest bet.
It’s always possible that Ethernet is optional - or hasn’t been connected internally, although the reseller’s web page that I found seems to indicate it’s standard.

Note that there are two connection schemes for Ethernet cables - ‘A’ and ‘B’. (see Network Cables A vs. B Ethernet Wiring | StarTech.com) Most modern devices can sense the cable type and automatically configure themselves, so I very much doubt it is the problem, but if all else fails, it might pay to check and see if you have both types and can try the other one.

This page https://kb.solaxpower.com/data/detail/ff8080818407e2a701840a22dec20032.html is about setting up ModBus, but the first part is about a WiFi connection, so it might help.

Can you post a photo of this?

The need for port forwarding would be highly unusual in this day.

This is only relevant to ‘passive’ infrastructure not ‘active’ devices. Active need power, passive do not. i.e. the port on the wall of an office is connected to a patch panel in a room is passive. This can be wired either A or B (makes no difference as long as within the same infrastructure it is all the same). When you connect an active device at each end via a patch cable, it again makes no difference.

You not ever see active devices sold as A or B!

As I wrote:

Trying a different cable never hurts - they can get damaged.

No, active devices don’t care.

Yes but bringing A/B into it is a rabbit hole.

The point is, if it’s not an intelligent device, the twisted pairs in the ‘wrong’ cable won’t be paired correctly. As I wrote, “very unlikely”, but over the years I’ve learned the hard way never, but never, discount something you believe and everyone else tells you is impossible. Because just occasionally, everybody is wrong - hence “if all else fails”.

1 Like

Hi,
@Jobsworthy
have a look on the ethernet device hopefully it will give you a MAC address, you need to look in the routers DHCP table for this address and note the IP address that the router has allocated to this MAC this will be the IP (local) the router has allocated to the inverter. It will be in the format 192.168.x.x. Where are you located? If you need it am happy to try to help over the phone, just let me know. However this is something your installer should be doing though they may not be fully IT literate

John


Is this what you mean?

The cable seems to work ok.

Hi @JJC

The problem is that I don’t have the MAC address. It isn’t on the dongle, inverter or any of the paperwork I have.

If I plug the network cable into my laptop instead of the ethernet point, will I be able to find out the MAC address that way?

@Jobsworthy

If the dongle you have works similar to mine it will show on your router table as a set of digits the same as the serial number of the dongle. If you find an address that looks like this you could try to “ping” it from your PC by putting a command like this into a command prompt. try ping 192.168.1.xxx -t this should produce a continuous response, to see if you have the correct address if you unplug the cable from the dongle the ping should fail and resume when you plug it in. You can terminate the ping by pressing ctrl c

Hope this helps

John

Is that cable an ethernet cable? Is it then plugged into the main router?

If so, you should be able to go to the router web interface and see what the IP & mac addresses are.

@borpin
The problem is that, although I can see all the MAC and IP addresses via the router portal in my browser, I don’t know which, if any, of them relates to the inverter, as it doesn’t say.

I’ll ask again, is that an ethernet cable plugged into the router?

If so, look at the port number. It should be on the socket itself and the router should refer to physical port on the web interface.

If not, you just need to unplug it and look to see what IP/MAC drops off.

The ethernet cable is plugged into the ethernet point in the wall. That, along with the other ethernet points in the house, are connected to a “switch” in the loft which, in turn, is connected to port 2 of the router. This means that all devices connected to the internet via the ethernet points in the house appear as being connected to port 2.
Also, when I disconnect the inverter from the ethernet socket, there is no change in the list of devices.

Does your router have, possibly under “Advanced” or similar, a page where it shows the traffic to each device? If so remove/delete all those showing no traffic, make a list of those that are left, then plug in the Inverter. With luck, it will re-appear on the list of devices.

@JJC - I think that has identified which IP address it is! Thank you.

Next question…
When setting up port forwarding following these steps -

Do you know which ports I should use for WAN and LAN? The above instructions appear to suggest that I can choose any port, but is that right?

Thanks

I’m thinking it’s 22 (which appears to be SSH), but no luck with connecting the inverter yet. May need to wait for something to reset somewhere.