Community
OpenEnergyMonitor

Community

Significant OpenEVSE WiFi 2.0 Firmware Update. Call for beta testers

Tags: #<Tag:0x00007f6e13df7c98> #<Tag:0x00007f6e13df7ba8> #<Tag:0x00007f6e13df7978> #<Tag:0x00007f6e13df7888>

it’s impossible to go further

I finally got home from this work trip and I have to get my OpenEVSE working. I tried programming it per the instructions at https://openevse.dozuki.com/Guide/How+to+Load+OpenEVSE+Firmware+%28WinAVR%29/7 but all I get is an error as below.

I am using a USBASP V2.0 with the OpenEVSE powered from the wall, I have double checked my physical connections and reloaded the driver for the USBASP all to no avail.

I figured it’s better to ask a stupid question here before I make it to the drawer full of hammers in the toolbox.

Any advice? What simple thing am I missing here? Would Linux help? I have another computer next to the thing running linux rather than my Win 7 64 bit laptop.

It looks like you’re nearly there. Double check your connections, it could either be that you have some pins mixed up on the ISP connections or your ISP programmer does not power the unit. Try again with the unit powered up. Be sure to close the enclosure and stay safe if powering from the mains. You can also power via 5V DC via UART header which is safer.

I tried every possible iteration that I have available to me - USBASP v2.0, Sparkfun Pocket AVR programmer, FTDI programmer, AVRdude on Linux, Windows 7, Windows 10, Arduino IDE, nothing and no combination of those things worked - every single one comes back with ‘Target doesn’t answer’. I even added the J3 jumpers to the USBASP for ‘slow’ programming, to no avail. I can’t have my main charger not working, so I swapped the lead going to the car with my 30A unit that I had built to be L1/L2 as a portable unit and replaced the dead unit with it.

Now, I at least have a functional EVSE, but the 50A unit I took down doesn’t do anything at all, and I have no idea how to access it for reprogramming.

Jake

Off topic, I am on v2.7.0. Can I upgrade to v 2.7.3 over the air? I do not want to mess it up as it seems to be working well.
Thanks for any help.
Geoff

I don’t have an OpenEVSE but I have my own NodeRed flow to do much the divert logic against an ABL EVCC. I have found that the PWM can be varied at the lowest granularity and that my Outlander happily tracked the available current at a 0.06A resolution. The graph in the first post seems to be at a 1A granularity - if this is the decision tree I do suggest trying floating point :slight_smile:

Yes, we’ve extensively tested updating from 2.7.0 to 2.7.3 via the HTTP updater in the web UI with no issues. It should always be safe to update to latest stable release version using HTTP updater. The releases are always tested before release.

Nice! that’s interesting. I think 1A increments is adequate for most use cases.

Thanks Glynn!

3 posts were split to a new topic: OpenEVSE Solar PV Divert (Eco Mode) Improvement Suggestions

9 posts were split to a new topic: DIY OpenEVSE Setup

I updated the wifi firmware from v2.7.3 to V2.7.4 via the web interface,
On LCD appeared “wifi update complete” and now I can not link.
I tried the 10s and 5s button, it does not go to AP mode.

What can I do to get wifi link back?
Thanks.

What happens when you cut power to the whole unit then re-apply power? The Wifi module should print IP address at startup. It might still be connecting to your original network with a different IP.

After power up again, after initial check up,
There is no wifi version info neither ip info.
It goes to Ready and there is no more info about wifi.
I cheked the router and there is no other link with different IP.

Mmm it sounds like the WiFi module is not starting up at all. Are you able to reload the WiFi FW via serial UART? If not please email [email protected] and we will arrange a replacement. Sorry for the hassle.

It is working again with the replacement module.

Thanks

1 Like