Setting up Light wave rf and emonPi

I have an emonpi and 3 Light wave RF plugs. I’ve added the OOK module to emonpi. Can someone point me to some instructions on how to set them up so that I can use node red to control the plugs please?
I have tried openhab to see if they work anyway, but they don’t.

Let me know if you have any trouble setting up. I use LWRF from emonPi to control plugs in house daily. Works great.

To set up you can control direct from MQTT. Use MQTTlense chrome extension to connect to emonPi MQTT server then publish 1 0 to turn on LWRF 0 and 0 0 to turn off. You will need to pair with your plugs.

See MQTT emonPi info:

Once you have MQTT control working you can then use openhab to control. This should be set up already on the emonPi:

Thanks Glyn!
MQTTlens looks like the missing link to get pairing set up. I’ll try this later.

I’ve got a connection in mqttlens, however I haven’t had any luck getting a plug to switch!
What should I be putting in the Subscribe, Publish and Message boxes please? I’ve tried every combination I can think of…

To turn plug 0 on you need to publish to the lwrf topic message 0 1 then to turn plug 0 off publish 0 0

The same to turn plug on publish1 1` to lwrf

You will need to put your plug into pairing mode the publish the ‘on’ signal to pair the plug with the emonPi.

Still nothing. Is there an easy way for me to test the transmitter I soldered onto the emonpi?

Can you post a photo of the OOK soldering onto the board so I can check the connections?

Do you bridge the antenna connection as described on the wiki: EmonPi - OpenEnergyMonitor Wiki

Here’s a pic-

I did bridge the antenna.
In the absence of anything else, I could try removing the bridge and using a whip. What length should I try?


Looks perfect, nice work :slight_smile:

What sort of LWRF units are you trying to control?

Can you connect to the emonPi via SSH? Can you take a look at the lwrf service logfile,

cat /var/log/syslog | grep lwrf

Do you see any entries?

Have you been able to connect the emonPi MQTT server via MQTTLens? Can you see any entries in the logfile when you publish to lwrf MQTT topic?

See here for the technical details of the LWRF MQWTT service e.g how to view the logs / restart etc

Heck, I think this is going to stretch my IT skills! I’ll brush up on my command-line stuff and get back to you :slight_smile:

I’ve got the LW381 set, 3 plugs and a remote.

Seems to work great with the supplied LW remote, but I doubt I’ve got it to pair with the EmonPi. Any hints appreciated!

Instructions on how to connect via SSH are documented here: Service Credentials - Guide | OpenEnergyMonitor

Hi. Can I ask for some help on this. I really have no idea about coding, so am trying to do this with the help of your guides. On node red I have it set up to publish 1 1 to lwrf topic when I’m producing more than 2000kW solar. To make sure this works I have also set up an email alert

and this is what i have set it up to do

Using Putty I get the following fro the lwrf service logfile -

What am I doing wrong?

2 MW ? Really? You must have a pretty big solar farm! A typo, methinks.

Meant W not kW. Issue remains the same however.

Good effort, I think your nearly there.

The default lightwave RF MQTT topic on the emonPi / emonSD is just lwrf NOT emon/lwrf

Thanks Glyn. I am now doing a happy dance around my kitchen as lights automatically go on and off!

So, I thought I was there but I’m having a nightmare pairing the Lightwave sockets with the Emonpi. I have one done, but I’m not entirely sure how I did it! Any foolproof tips on pairing? Also the one I have paired stops working if I move it to a different power point and starts working again when I return it to the power point it was plugged in to when I paired it. Any ideas why or how this is happening?

Fantastic! Yes, pairing can be an issue with the LWRF plugs. It just a case of setting up the pairing then not moving them :-/

Any foolproof methods of pairing you can suggest?

I don’t think there is, this an inherent LWRF issue. I have the same pairing issues using the original LWRF remote. If I don’t move or power down the pugs the pairing has been working great for me for the past couple of years. I use LWRF daily to control plugs in my home.