Community
OpenEnergyMonitor

Community

Setting up a new device (Split Phase Energy Meter) on EmonCMS

jdeglavina Do you have a topic/forum for specific questions for this hardware? I am using the prebuiltSD from 2018, and the inputs when I try to set up a new device do not match what your hardware is sending via MQTT to my PI.

If you can post some details in https://github.com/CircuitSetup/Split-Single-Phase-Energy-Meter/issues I can take a closer look. Someone here may be more familiar with that version of EmonCMS though.

I can do that. I tried first to install from ‘scratch’, but couldn’t get the EmonHub to start. That’s why I went with the image.

@cyberward I split this out to a new topic as it seems more general re EmonCMS.

The Device templates are just that, templates for creating the right feeds from certain inputs that a specific ‘device’ generates.

@jdeglavina, if you expand a bit more on what data is available at the Inputs, and how you process that, then we should be able to get Chris going.

Thanks @borpin!

The fields that are sent from the default split phase meter are coming from EmonESP MQTT:
V1
V2
totV
CT1
CT2
totI
W
PF
temp
freq

totV & totI = total voltage & total current
CT1 & CT2 = current
W = total power
PF = power factor
temp = temperature in C
freq = frequency in hz

The solar kit, which @cyberward has, adds to the above fields:
SolarV
SCT1
SCT2
totSolarI
SolarW

Thanks.

May help if you could post a screenshot of your inputs and feeds page (the ones relating to this anyway).

here you go:


1 Like

So, I get a bit stuck here. If I create a set of inputs off of the Split Phase Energy Meter template, I get this:

This does not match what John has. So, I then tried to change VA and VC to V1 and V2, but I can’t seem to do that. Are you stuck with the template once it is created? Maybe I missed something with the wrench on that edit page?

I do see that on the Github for this project there is this file:


Is this a template that if I put it in the right place I could use? It looks like the right codes.

I think I see the problem. I didnt realize you had the device plugin loaded (or is it loaded by default in that build?). The devices plugin needs the template file updated to the one you pointed out in the repository. It also needs a seperate one for the solar kit, with the additional fields. I’ll get that created.

I first tried the manual install of all the pieces on my RaspberryPi, but I couldn’t get the EmonHub to start properly. I am suspicious that maybe it is not needed if I am using MQTT to talk to my Pi, so I can try latest code sometime, the SD build is a bit old. Did I miss a step with instructions how to put the templates in the correct place? It looks like these updates are not yet in the EmonCMS code base - for sure not in the version I have.

As per your other post, yes.

We have nearly got to a point whereby emoncms can be installed via a script so things like the EmonHub can be excluded at that point.

The Device Module is installed by default. I think other things now assume it is there as well.

Not sure this has been tested recently - @TrystanLea - any comments?

Ohh, okay, that explains it!

I just cleaned up the json file and added one for the solar kit. Should I just create a pull request in the device repository, @TrystanLea ?