Serial Device Not Found

Hi, I’m just getting started setting up my emonTX4. I have plugged a USB C cable into the TX4 and when I click on Connect, I get a popup that says “No compatible devices found”. I have tried 2 different computers and 2 USB C cables and tried this on both Chrome and Edge with the same result.

I have two emonTX4s (both with Wi-Fi radios) and neither will connect. I see a red light next to the USB connector in the TX4 that flashes approximately every 8 seconds.

Not sure what I am doing wrong.

Thanks, Gordon

Hi Gordon,

Have a look at this thread:

If you don’t look back up that thread Bill’s pointed you at, the short answer is, apparently to keep the build price down, the USB-C connector IS POLARITY SENSITIVE. Turn it over and try again.


I had noted the orientation of the USB-C connector in an earlier post and tried that. I have also noticed that my computer only plays the “connected” sound when plugging in a USB device in one orientation. It doesn’t in the other orientation – so this is a good indicator if the USB-C is in the correct orientation.

However, I am now using a known USB-C cable that I use for firmware updates on other USB-C devices, so it is a data cable, not a power only cable. I still get the same message regardless of browser (Chrome or Edge).

Is there another way, other than the USB connection to setup the emonTX4?



This indicates that the emonTx4 is actively running the pre-loaded sketch, so that’s good. I don’t use Windows, I don’t know if there’s a specific setting you need to change (but if other devices communicate on the same port, this can’t apply), so I can’t really help any further. @Bill might like to come in again, otherwise it’s @TrystanLea or @glyn.hudson

Unfortunately I don’t think so. The Wi-Fi module might be able to handle OTA updates, but I’m not aware that it does. In essence, this is what you need. The RJ45 socket is of course not Ethernet.

Hello @grod55 , do you have the Arduino IDE installed? can you check if the emonTx4 lists as a serial port there? It is possible to configure by sending serial commands manually via the Arduino IDE serial console, so that might be a good avenue to pursue?

The serial commands are listed here: Configuration — OpenEnergyMonitor 0.0.1 documentation

Hi TrystanLea,

I do not have the Arduino IDE installed. So, thinking about this, I checked Device Manager in Windows and see “Other Devices – CP2102N USB to UART Bridge Controller” with a yellow warning triangle. Clicking on this shows “the drivers for this device are not installed (Code 28). There are no compatible drivers for this device”. I am now on the hunt for a compatible windows driver.

I was able to find the driver at this site and I am now able to access the TX4.

Thanks for the help!



Perfect thanks @grod55

If you do decide to install the Arduino IDE, instructions are here: Using the Arduino IDE — OpenEnergyMonitor 0.0.1 documentation

Or just RTFM (Trystan’s link)

@TrystanLea - Windows should have a capital letter and perhaps this needs more prominence in the docs.

There’s all the information needed in my link too. But when people go their own path, there’s very little anyone can do.

Hi Brian and Robert,
I do appreciate the amount of support in the community as I wade through the documentation and multiple posts. For the newbee it is a bit intimidating and hopefully one day I will have the knowledge that a lot of you have.

Your patience is appreciated.

Thank you



I think our problem was, you hadn’t mentioned and we had no means of knowing that you weren’t using the Arduino IDE, or even what OS you were using. I actually thought when you mentioned Chrome and Edge you had connected via an emonPi - which of course would have worked first time because Linux (which most of us here use) doesn’t require drivers for this.

The point to remember is, we don’t know what you’re thinking; we only know what you write here.

1 Like

Fair point. I will try to be as clear as possible going forward. Again, I do appreciate all the help and support.