Serial connection to emontx v4 with Ubuntu Documentation addendum

Hi guys,… just in the process of setting my emontx v4 up,… and reading the instructions,… got to the connect via serial to chrome etc,… and things failed,…
figured this maybe a permissions issue,… so added my local user to the ‘dialout’ group ,… comms enabled problem fixed.
so basically, a requirement to Linux users, when trying to serial connect to emontx V4,… local user must be added to dialout group,. the following command should fix, followed by a reboot

sudo adduser local_user dialout
1 Like

In addition to rebooting, logging the local_user out, then logging them back in, will also work.

1 Like

Yes indeed Bill you are correct,… but I was just following the path of ‘KIS’, with no ambiguity ,… i like my setup guides to be ‘idiot proof’,… :grinning: to help people like myself… :grinning:

1 Like

Nothin’ wrong with that! thumbs_up thumbsup

Can you just clarify. Is this trying to connect to the TX4 via USB from an Ubuntu installation?

Can you clarify the setup and hardware in use, please?

Hi Brian,… This was 22.04 Ubuntu install, ( on an intel nuc )…using latest chrome browser.
I have since tried the same thing on my Open-energy Raspberry Pi , used for logging etc,… and this connected without issue.
Hope that helps

So emoncms installed on Ubuntu 22.04, the TX4 conneted via USB, and the browser running on a different machine?

Brian… not quite,… this was plain ubuntu Desktop 22.04 install,… no emoncms etc…
My emoncms ubuntu is a raspberry pi,… as purchased from Openenergy

1 Like

So this is actually nothing to with the emonTx V4 specifically, but applies to any serial connection to your Ubuntu Desktop 22.04.

Quite correct… not an issue with the emontx v4,… its if one uses a ubuntu desktop install,… and tried to create a serial comms link to the emonTx v4,… the i/f just sits there, and does nothing.
The dialout group came to mind as I have experienced this issue with serial comms before, with previous ubuntu installs.

I’ve run into the same issue with Redhat, Fedora, Slackware and Debian as well as a few
non-mainstream distros. (e.g. Puppy, Damn Small and SliTaz)

Ok, thanks. Where would you expect to find this info in the docs?

My suggestion would be within the following docs:-


3. emonTx4 Installation

there a NOTE as follows:-

The USB-C connection on the emonTx4 only works in one orientation for data transfer (usually smooth face up). If the config tool doesn’t connect then invert the orientation of the plug.

I would add,…
If connecting via a Linux Ubuntu ( or similiar ) based machine and connection apparently fails,… check that your current user has dialout access granted,
type:- ‘grep dialout /etc/group’ to check, expect response
dialout:x:20: where local_user is not listed,
if current user not referenced in output above
type:- sudo adduser local_user dialout to resolve followed by logout, and back in or reboot
type:- ‘grep dialout /etc/group’ to check, expect response
dialout:x:20:local_user where local_user is now listed.
Other Linux system use similar commands, but check.

Hows that…
Thats my 2pennies worth… :slight_smile:

1 Like