Community
OpenEnergyMonitor

OpenEnergyMonitor Community

RFM69Pi V3 receive data

Tags: #<Tag:0x00007f681f23a238>

I bought a RFM69Pi V3 module (868mhz) to be able to receive data from my nodes (also sending on 868mhz).

I disabled the serial console. Then I connected the module to my Raspberry Pi (running raspbian jessy) like so: http://puu.sh/phLxR/7b16354b0b.jpg When I power on the raspberry the red LED of the RFM69Pi is on for a few seconds, then never again.

minicom -b 38400 -o -D /dev/ttyAMA0 is giving me a very strange output: (one line adding approx. per second even if my sender is not sending at all)

? G0 152 60 133 124 241 123 183 82 4 124 7 22 75 11 63 95 86 17 179 31 27 (-85)
? G0 60 63 33 219 155 180 40 207 104 57 193 130 23 234 231 233 18 95 124 60 37 (-84)
? G0 158 249 252 243 24 125 45 232 65 232 115 198 168 146 184 202 220 30 157 138 239 (-84)
? G0 43 127 94 219 88 232 60 94 29 13 215 52 177 40 60 85 95 238 122 252 168 (-85)
? G0 154 241 113 179 110 211 45 38 162 49 175 242 119 229 29 193 83 157 212 87 235 (-89)
? G0 3 82 93 239 25 66 221 124 51 2 11 249 7 158 147 140 26 204 216 47 136 (-87)
? G0 182 217 110 144 153 85 95 106 248 0 64 127 130 233 217 95 152 106 184 7 44 (-86)
? G0 62 140 242 203 73 48 68 162 54 197 205 166 82 183 214 117 248 71 122 177 245 (-88)
? G0 133 48 92 165 5 22 7 126 246 96 156 56 21 188 16 67 38 214 214 80 211 (-85)

On this page: https://wiki.openenergymonitor.org/index.php/RFM69Pi_V3#Debugging at the very bottom they say it should look different. In another post I could read that G0 may stand for group 0 which should be 210. They say it is possible to change it in minicom but I don’t get it. If I type s.th. like “210g” I don’t get any response from minicom and the above lines keep adding. How can I setup the RFM69Pi V3 to receive 868Mhz data with group 210 ?

In minicom do you get a response to typing a v and entering? or a ? and entering?

It would be good to establish if all commands are ignored or if the settings are locked, the current configuration output from either v or ? should confirm if locked and the? should give you the help text to see the fll list of options including how to unlock the settings if locked.

As you’ve discovered, whilst in minicom typing command string 210g and enter. should switch it out of “all groups” mode (which is set by using 0g).

Once out of all groups mode you should see your nodes, there is a wrinkle in the way the all groups function works and it actually gives you all groups except the configured group so the absence of your expected nodes isn’t significant until you exit all groups mode. If anything it may confirm you device was set to group 210 prior to being set to 0g

Do you have a transimitting node nearby and turned on?

The serial output you are seeing with ‘?’ is discarded packets that are being ignored. You can turn off display of discarded packets by turning on quiet mode by sending serial command 1q via minicom.

In emonHub.conf you will need to set the frequency to 868mhz. emonHub config can be edited in the Setup > EmonHub tab of local Emoncms

Thank you for your answers.
When I type “v” or “?” in minicom nothing happens (same when pressing enter afterwards). I’ve just reinstalled raspbian jessy and it didn’t change anything. https://community.openenergymonitor.org/t/rfm69pi-getting-started-basic-question/260 There I could read that sending a ? will list all available commands… it won’t work for me. It doesn’t even seem like I can type anything at all, minicom is just listing the lines mentioned above. Only thing that works is strg+a + z. I can then use all options listed in the help screen, but I do not see a single way there to configure the RFM69Pi.
I can not find any descriptions on the internet about a “?” command like: http://manpages.ubuntu.com/manpages/xenial/man1/minicom.1.html

When you see the list of commands can you see the current settings listed at the bottom e.g.

Available commands                                                            
  <nn> i     - set node ID (standard node ids are 1..30)                        
  <n> b      - set MHz band (4 = 433, 8 = 868, 9 = 915)                         
  <nnnn> o   - change frequency offset within the band (default 1600)           
               96..3903 is the range supported by the RFM12B                    
  <nnn> g    - set network group (RFM12 only allows 212, 0 = any)               
  <n> c      - set collect mode (advanced, normally 0)                          
  t          - broadcast max-size test packet, request ack                      
  ...,<nn> a - send data packet to node <nn>, request ack                       
  ...,<nn> s - send data packet to node <nn>, no ack                            
  <n> q      - set quiet mode (1 = don't report bad packets)                    
  <n> x      - set reporting format (0: decimal, 1: hex, 2: hex+ascii)          
  123 z      - total power down, needs a reset to start up again                
Remote control commands:                                                        
  <hchi>,<hclo>,<addr>,<cmd> f     - FS20 command (868 MHz)                     
  <addr>,<dev>,<on> k              - KAKU command (433 MHz)                     
Current configuration:                                                          
 E i5 g210 @ 433 MHz  

The config of this module is 433Mhz 210 network group

‘v’ should work for you since you have the latest module.

Example commands:

  • 8b - set frequency to 868 (default 433)
  • 210g - set group to 210 (default)
  • 1q - turn off quite mode (don’t return bad packets ‘?’)
  • p - list avialble commands
  • v - return version (only supported on newere RFM69Pi)
    ``

There should be no need to use minicom. Do you intend to use the RFM69Pi to post to Emoncms? If so, I would recommend using latest pre-built SD card image and configuring the module via emonHub . You should set 868mhz in emonhub.conf

I will try this image,
but I dont see the “commands” the only commands I see looks like this:
http://puu.sh/pj3se/22e584fd1a.png

and as I said when I press “v” nothing happens…
Edit: Same issue with the sd-card image

Ah, when we say ‘commands’ I mean the RFM69Pi serial commands as I posted above. Try pressing ‘v’ or ‘p’ when minicom is open and displaying data.

What you have shown on your screen grab is the minicom commands, that is not what we want.

nothing happens…

I don’t get it. You all say “press v or press ? or press p”. I’ve now read every single thread on the internet about minicom and rfm69pi. I’ve installed jessy like 3 times, even tried the openenergymonitor image. I’ve used raspberry pi model 1 and 2 and I pressed every single key like 500 times when minicom is open and there is no way that I can send a command (like set frequency / network id) to the rfm69pi.

Very sorry for this hassle. It sounds like you may have a hardware issue although it’ very strange that you can receive data from the RFM69Pi but not send data.

See screencast demonstrating sending serial using minicom:

Could there be something else interfering with the serial transmission e.g. Linux terminal? Before RMA Could you try with our pre built SD card image to make double sure there is nothing interfering with the serial link:

Thank you for your help.
What I’ve done for testing:
I’ve connected pin 8 and 10 of the raspberry using a jumper wire. When I open minicom now and type s.th. I can just read what I typed. As far as my knowledge can tell me, minicom is sending everything I type to the serial port and displaying everything which is received from the serial port in the console (correct me if I am wrong).
Which means, that the RFM69Pi should respond via the serial port when I send the letter “v” or “?” to the serial port by typing it in minicom? If this is the case, my RFM69Pi should behave differently. In order to check if the RFM69Pi is not working correctly I just orderd a new one :slight_smile:. I have used the pre-build image, raspbian wheezy and a newly installed raspbian jessy so far, all behaving the same way (as described above)

It sounds like maybe you have a hardware issue with the RFM69Pi. Thanks for ordering another, however I was about to send you one anyway! I have refunded the cost of your new order. We will ship the new module today :slight_smile: