Community
OpenEnergyMonitor

Community

RFM69Pi: "Device communication error" message


(daturach) #1

I am running a system with a EmonTx V3 + RFM12 and a Raspberry + RFM69Pi with firmware “Pre-Release Development Version (rc1.2)”.
From time to time (once a week or so), I get a “Device communication error - check settings” message while rebooting the Raspberry. This is quite annoying because I have to unplug/plug the Pi to bring the system back online.

Is there anything I can do to fix this on the software or hardware side?

Thanks for your support

Walter


(daturach) #2

I am going to set the loglevel to “debug” and monitor the log file. Will report back …
Walter


(Paul) #3

Hi Walter
Have you set the baud in emonhub.conf for the rfm69pi? all rfm69pi’s are 38400, the auto baud detection in emonhub is not perfect and can sometimes fail to recognize the correct baud. If you know your baud it is always a better option to explicitly define it in the conf.
Restarting emonhub with sudo service emonhub restart is usually a better option than power cycling the Pi.


(daturach) #4

Hello Paul
Yes, it’s set to 38400 in emonhub.conf.
sudo service emonhub restart : agree, the best option

As I said, I will monitor the log in the next few days.
Thanks for your help.
Walter