Return to grid reading for Home Assistant

I am try to integrate Emonpi with home assistant so i can turn plugs on etc to use excess solar instead of exporting. I have got import and solar readings but cant find or work out how to get return to grid reading? Any help would be appreciated Thank you.

I just log the readings off the CT clamp on the grid connection.

If negative, log to ‘export’. If positive, log to ‘import’.

Seems to work for me.

The instructions allude to the use of positive/negative readings here

Think i am sort of getting there, how do you add export to feed?

does this look ok? do i need to add power to kWh/d import and will it mess up my solar app display? If this is correct it is not showing in home assistant, my energy, return to grid options

I think your Step5 should be +input rather than -input.
Otherwise you’ll turn an export into an import/import into an export.

The Power to kWh & Power to kWh/d is fine, it’s using the Power figure and doing the Power to Energy conversion itself.

I’m not doing this in HA yet, so I can’t help you with that, but the -inp/+inp may not be helping.

ok Thanks Lee

i Have been trying different things to get this to work over the last few days and failed. any help would be appreciated, as i am struggling a bit. This is my energy distribution, should have an import and export to grid i believe, to work properly?

@Hailstoneuk you’ve got part of it above.
The “allow positive” on the GRID CT is your grid import.
The “allow negative” on the GRID CT is your grid export.
The solar CT is always positive, so log that.
To log what the house is doing, add the (raw) GRID CT to the SOLAR CT.
Eg. If the GRID is 250W (i.e. import) and the solar is 300W, the house will be using 550W.
Or. If the GRID is -350W (i.e. export) and the solar is 400W, the house will be using 50W.
Power to kWh/D (on each) will log the total energy used that day.

Makes sense?

getting there slowly. Export showing as - reading in home assistant. Still not showing in home assistant, my energy, return to grid options though.