Community
OpenEnergyMonitor

Community

[RESOLVED]Can't create dashboard, not same menu?

(Dimitri Chauvin-Hameau) #1

Hello,
I come here to ask a question about installing Emoncms, after following the installation guide on the site and setting up the “settings.php” file and creating my database, I create my administrator account, so I can create Node and power, but I can not create a dashboard, and I have the impression that I do not have the same menu as the others. Like it :

me:

But the others have much more action possible in their menu.

I naturally install it all on a local server with like windows OS.

Thanks for any helps ! see you.

ps : Sorry for my english i’m french :disappointed_relieved:

(Eric Wouters) #2

Hello Dimitri

Will help you in French, in short for others, you need to install more modules once emoncms is installed.

Je suppose que tu as installé ton emoncms chez toi ou sur un site à toi et non la version emoncms.org gratuite en ligne. L’installation de base étant faite, tu peux ajouter des modules comme celui des dashboards

Tu trouveras des modules sur cette page Github

le 5ième module étant celui pour ajouter la fonctionnalité des dashboard. Tu charges le module en local (sous le bouton vert : download zip) , tu renommes le répertoire (enlever master etc, juste laisser le nom du module) et tu le mets alors dans le répertoire module de Emoncms
tu recharges ta page et voilà le nouveau module actif. C’est pas sorcier à faire.

bonne découverte

(Dimitri Chauvin-Hameau) #3

Hello Eric!

Thanks, i didn’t see that before, i just tested now and it’s ok ! thanks for the answer quick ! see you !

(Bjarni) #4

I ran into the same problem, figured out I had to install the dashboard module, I am running this on Shared Linux Host(if that does matter) what I did is I downloaded the dashboard-stable.zip and extracted it under emoncms/modules… If I press Setup (when in emoncms) I have now have the Dashboard option there but when I press +New to create new dashboard nothing happens. any clue why that might be?

(Bjarni) #5

sometimes you just have to ask to figure out the answare… I had not updated the database after I installed the dashboard module… so for others… go to Setup->Administration->Update Database… Now it works

1 Like
(Robert Wall) #6

That is well-known, there is a name for it: Rubber Duck Problem Solving. The concept is that when you explain your problem so clearly that a rubber duck could understand it, the solution becomes obvious to you.

2 Likes