Recommended tablets

Hello, are there any suggestions on low cost tablets to use with EmonCMS?

I’d probably get an Amazon fire, you can pick them up cheap new. That’s what I use, as long as it runs on Android then you’ll be able to download the app from the Google play store. Fire’s are semi locked to use Amazon apps but you can add Google play store easy enough, plenty of info on YouTube.

All-New Fire HD 8 Tablet | Hands-Free with Alexa | 8" HD Display, 16 GB, Black - with Special Offers

I’ve found the cheapest tablet for this purpose is the old one you’ve just replaced with a new one!

1 Like

Ok, I was wondering about that. I tried my old IPad 2 yesterday and all of these error messages popped up on the screen about syntax errors etc. Is it possible the iPad 2 is two old?

What iOS is running on your iPad 2? The latest supported by Apple was 9.3.5, which is from 2016. Did you get errors when using the “MyElectric” App or just browsing to EmonCMS page from Safari?

[edit] Just adding that my old iPad1 can barely run any modern web page, but it is stuck on iOS 5!

Ok,it’s running 9.3.5. The error that comes up is syntax error: unexpected identifier ‘response’,’value’,’markup’, and reference error: can’t find variable: processlist_ui. running on Chrome and Safari.

I would check in to the fire tablets. i picked up a 7inch for like 35 bucks. it’s not difficult to side load the google play store, so you can add all the necessary apps to make it fully functional for wallmount dashboard style stuff. That’s what I am doing with mine for openhab.

I’m still not clear on precisely what you’re looking at that is getting those errors?


Doesn’t actually help us work out what it is that you can’t get working :slight_smile:

Hello, sorry I forgot to mention these errors come from the Emonpi.local web UI only on the order iPad 2 device and does not appear when I’m using my iPhone 7 to access the web UI of the MyElectric app.


That’s the first time you’ve identified where the errors are coming from, so it is specific to the MyElectric app :slight_smile:
Do you get errors from any of the other EmonCMS web pages?
What version is running on your emonPi? Can you send the server details through from the admin web page?

Hello, I downloaded Firefox for iOS and it seems to be working fine still get the error messages on the older iPad 2 only. the iPhone and newer iPad mini running iOS 12 are not displaying any errors when running webpage UI or MyElectric app.

I also get errors in safari on iPad 2 accessing emonCMS, guesing it’s JavaScript functions/apis being too new for older browsers.

It runs NodeRed dashboard like a dream though to check up on values, but of course you need to create your dashboard, pull in data from emonCMS, which won’t be as straightforward as just opening myElectric app.

We had dashboard on an old 2012 Nexus 7 in living room, but that’s decided to pack up (dashboard had stopped displaying so tried installing firefox which seemed to really kill it). It had cyanogenMod so need to get round to installing a newer/lightweight Android OS with all the fun that entails.

Ive heard this dual boot tablet is good