Community
OpenEnergyMonitor

OpenEnergyMonitor Community

raspberry localhost

Hello everybody
I am currently sending data to emoncms.org with an arduino.
I want to expand my system this year and double the number of feeds.
Therefore I would like to switch to a localhost to reduce costs.
I own a raspberry 3 (no experience) and have been trying to install emoncms for days with various instructions. so far without success.
I would like to start over with the installation and hope for your support.

Question is this guide the right one for my project?


Or schould i try another?

Michael

Welcome.

Short answer, no.

As it says at the very top of the page

ok i will try

1 Like

I have installed the image from this site:

https://github.com/openenergymonitor/EmonScripts/blob/master/install/readme.md

the raspberry shows emonpi login:

Whats next: " Install the EmonCMS Installation Scripts" ?

<

If you have installed the image there is not much else to do.

Nothing to install - Emoncms is preinstalled.

that sounds good. How can I access the localhost? Do I have to adjust settings? Is there a graphic interface?

I tried to connect via browser β€œhttp://emonpi.local/” or IP adress and get the following message

Can’t connect to database, please verify credentials/configuration in settings.ini
Error message: Connection refused

/var/www/emoncms/settings.ini

emoncms_dir = "/opt/emoncms"
openenergymonitor_dir = "/opt/openenergymonitor"

[sql]
server = "192.168.0.175"
database = "emoncms"
username = "emoncms"
password = "emonpiemoncmsmysql2016"
; Skip database setup test - set to false once database has been setup.
dbtest   = true

[redis]
enabled = true
prefix = ''

[mqtt]
enabled = true
user = 'emonpi'
password = 'emonpimqtt2016'

[feed]
engines_hidden = [0,6,10]
redisbuffer[enabled] = true
redisbuffer[sleep] = 300
phpfina[datadir] = '/var/opt/emoncms/phpfina/'
phptimeseries[datadir] = '/var/opt/emoncms/phptimeseries/'

[interface]
enable_admin_ui = true
feedviewpath = "graph/"
favicon = "favicon_emonpi.png"

[log]
; Log Level: 1=INFO, 2=WARN, 3=ERROR
level = 2

You appear to have changed this - have you setup the database on this host?

yes i have changed that from 127.0.0.1 because my raspberrys ip is on 192.168.0.175.
mistake?

How can i setup the database on this host ?

just leave it as the local host IP

it works !!

Thank you