Community
OpenEnergyMonitor

Community

Rasbian Buster with Desktop but no Bluetooth

Tags: #<Tag:0x00007f6e0f664980>

Hello everyone
I have several raspberries working with rasbian (initially with Stretch and now with Buster) all with desktop and emoncms and domoticz, everything works perfect.
The only thing is that I can’t use bluetooth, it disappeared.
During the installation of emoncms on Rasbian with desktop, the Bluetooth icon is in the upper right corner, but after the last command of the installation (chmod + x init.sh && ./init.sh) and after restarting the icon of the bluetooth disappears.

I have tried everything to make it work but I have not been able.

please help

How did you install emoncms? Assuming a Pi 2/3 (not sure about the 4, bluetooth and one of the serial ports are shared. I think the standard install of emoncms effictively turns off the bluetooth.

There is some info in this post Multiple problems w. EmonTx and RFM69Pi

@TrystanLea , perhaps configuring the serial port should be an actual option in the install scripts rather than a decision based on the RPi environment flag.

@borpin you probably meant @TrystanLea

1 Like

Here’s the section in the install scripts that disables the bluetooth in order to enable serial support:
https://github.com/openenergymonitor/emonhub/blob/master/install.sh#L26

Can you reverse these commands @jvm1000?

True, happy for that to be the case

1 Like

I did an install on Pi 3
trying to revert the lines you told me
insert on /boot/config.txt
#dtoverlay=pi3-disable-bt
and
sudo systemctl unmask [email protected]
sudo systemctl enable [email protected]
sudo systemctl start [email protected]
sudo systemctl enable hciuart
sudo systemctl start hciuart
sudo reboot

after reboot nothing change, there is no bluetooth icon on righy top corner
systemctl status bluetooth
loaded and active
systemctl status hciuart
loaded and active

trying with
[email protected]:~ $ bluetoothctl
Agent registered
[bluetooth]# agent on
Agent is already registered
[bluetooth]# default-agent
Default agent request successful
[bluetooth]# scan on
No default controller available

Problem, No default controller available, so trying more things

sudo apt-get install pi-bluetooth
sudo apt-get install bluez bluez-firmware
sudo apt-get install blueman
sudo usermod -G bluetooth -a pi
sudo reboot

and nothing change, i do not have more ideas :frowning_face:
thanks

Looks like you have tried everything I can think of there.

Perhaps it would be easier at this point to start from scratch and perhaps disable installation of emonhub?

Do you intend to use emonhub?

i do not use emonhub
i do not use emonTH
i use Espeasy and Domoticz

when i do the instalation, i do
1- https://github.com/openenergymonitor/EmonScripts/blob/master/install/rpi-install.md
---------Edit cmdline.txt and remove this text:
---------init=/usr/lib/raspi-config/init_resize.sh
---------I remove all the text after the init=/usr/lib/raspi-config/init_resize.sh
2- wget https://raw.githubusercontent.com/openenergymonitor/EmonScripts/stable/install/init.sh
3- chmod +x init.sh && ./init.sh

how do i disable installation of emonhub?
Thanks

At the start it asks you if you would like to review the config.ini file that configures the installation, you can disable emonhub installation here:

https://github.com/openenergymonitor/EmonScripts/blob/master/install/emonsd.config.ini#L27

1 Like

I did it
working perfect
Bluetooth icon is on right top and is working
Thanks a lot :grinning:

now with RPIeasy and Xiaomi Mijia Bluetooth Temperature i will try to save the temperature in emoncms

1 Like