Pulse sensor RPI directly

Hi Everyone

Just wondering if anyone knows if its possible too still wire the optical pulse sensor directly too the GPI of the RPI should it still work with the latest release of emonSD

like discussed in the older post

Welcome, Aaron, to the OEM forum.

As far as I’m aware, there’s nothing later that supersedes the Topic you mention, so as far as I know, it remains the recommended method. It’s been a long time now since we’ve seen a contribution from Paul, so I don’t know whether he’s likely to see this or not.

1 Like

Short answer - yes - I have one running. Sure I have posted about it, but no time to search. Been running since June 2020.

I used an adapter (from Amazon) as the sensor had an RJ45 on it (from the OEM Shop). Emoncms It is just emonhub install, not a full emoncms (buth that should work) running on a PiZeroW.

I use this emonhub interfacer but I think @TrystanLea posted that this was being deprecated.

Ah better - I’ve not looked at this in quite a long time (Feb 21) so will be using a very old version of emonhub!!! emonhub/conf/interfacer_examples/Pulse at master · openenergymonitor/emonhub · GitHub

This is my config.

[[pulse2]]
    Type = EmonHubPulseCounterInterfacer
    [[[init_settings]]]
        pulse_pin = 15
        bouncetime = 5
        # Rate_limit is the rate at which the interfacer will pass data
        # to emonhub for sending on. Too short and pulses will be missed.
        # rate_limit is minimum number of seconds between data output.
        # pulses are accumulated in this period.
        # rate_limit default to 2.
        rate_limit = 5
    [[[runtimesettings]]]
        pubchannels = ToEmonCMS,

        nodeoffset = 3
2 Likes

I have been trying for a few days too get it working alot of reading lol

I’m not sure but i think the sensor is DOA will try some more things first

All I’m trying too do is see if the sensor is working or not

Installed emonsd (PI3B+) latest version

enabled.ssh

Installed EMONHUB

Edited the emonhub.conf too add the optical sensor config

Pulse monitor does not receive any readings from my meter or flash in replete of my meters led

Nothing can be seen in the logs about pulses

OPS RJ45. <> FEMALE COUPLER <> MALE RJ45~ETHERNET<>DUPONT FEMALE

All connections tested with multimeter

Connection on the RPI
5v
GND
GPIO 13

At this point should I be seeing the pulse sensor in the logs

Where did you get it from?

You might be swapping pins on the RJ45 with multiple couplers. Some will swap, some pass through.

Just what I was thinking…

From the open energy store

There’s only one coupler

Sensor too <> coupler <> ethernet cable <> dupont

The coupler is just a standard keystone jack tested all connections with a multimeter everything seems connected properly


All you can try is power the sensor and see if you can see the 3.3 coming back with a pulse.

Definitely the right pin? GPIO number is different to Pin Number.

Set it for gpio 13 according too emonhub

What did you put in emonhub? Note it is Pin number not GPIO number.

Note my setup, it is connected to Pin 15 (as per emonhub config).

Gpio 13

“”““from emonhub””“”* pulse_pin: Pi GPIO pin number must be specified. Create a second interfacer for more than one pulse sensor

I think that might be incorrect…

Certainly my setup works. Connected to Pin 15, GPIO22.

You could argue it says “GPIO Pin number” not “GPIO Number” :slight_smile:

Swapped too pin 15 gpio 22 already tried a few diffenet pins over the days nothing has brought it too life pretty sure it’s a dead sensor

Still nothing in the emonhub log

Measuring the voltage with a multi meter

Measure
from power too data 5.1v
From power too ground 5.2

@Gwil Dead sensor?

1 Like

Days of research and testing down the drain if that’s whats actually up spent along time

was that tested how you wanted

Power too data on the right settings on the multimeter? I’m not a pro :slight_smile:

very little varience when testing 0.0X V

I have never seen the little green light flash on the OPS in the days of testing

I think it’s dead something must have worked by now it’s a fairy simple project

Ah, GPIO Pins are 3.3V not 5V!

I think 5V doesn’t do them any good (but I could be wrong).

Testing with the multi meter on the little dupont clips still all connected too the pi says 5v PWR-GND & PWR-DATA so it’s sending power back down the data into the pi gpio?

It doesn’t send data, it sends a voltage high/low to trigger the pin. so allows the voltage you feed in through back to the GPIO Pin as ‘pulse’. The Pi software then detects this ‘pulse’ on the pin.

Definitely not 5V tolerant.

Just checked that myself so should have powered the ops from 3.3v? Or the OPS is broken and is just sending voltage back down the line

My heads fried from it all just like my rpi :joy:

Yes. I’m not sure of the impact of the 5V. It might still work - try it :slight_smile: