Community
OpenEnergyMonitor

OpenEnergyMonitor Community

Programming ATTINY841 - error "target doesn't answer"

Hi, I’ve recently populated some 4.21 boards, however I’m struggling to upload to the ATtiny841. I think I am doing something wrong regarding the USBASP drivers / settings.

I get the following message in verbose mode when trying to upload to the 4.21 boards:
https://pastebin.pl/view/5eb1264b

I’ve tried reinstalling the drivers/ installing different versions with Zadig, but so far no luck in getting information over the modules.

This is a link to the specific module, if anyone could advise how to address my issue it would be extremely helpful, thanks.

I have the same problem. Months ago I was able to burn with a previous version of the software that does not have the n different sets of targets. I have used that since then. @stuart sent me some experimental module software, but in order to get that to work, I copied the source files into my old version.

I don’t know enough about the newer platformio.ini stuff to attempt to fix it. My old version was the fastest way for me to get going. I looked at the commit logs and did not find an obvious revision to grab. So, basically I am saying I agree, and have no solution for you. Sorry.

1 Like

Do you know which versions you ended up getting working?
Thanks btw

I have 421 modules if that is what you are asking. I don’t know how to easily find software version info.

Give this a go. I zipped up the module folder that worked for me.
ATTINYCellModule.zip (1.4 MB)

1 Like

Hi @Oscar_Allington

The error you have is “target doesn’t answer.”. Under the covers platformio uses AVRDUDE to program the chips.

Target doesn’t answer usually means:

  1. The ISP cable is unconnected or not wired properly
  2. The ATTINY chip doesn’t have any power (are you powering the module from the USB programmer?) - make sure the battery is disconnected
  3. There is a soldering issue with the ATTINY
  4. The ATTINY fuses have been incorrectly programmed and now the chip wants an external clock signal (very rare)

Hi Oscar_Allington you are right I had the same problem and after checking my connection’s to the ATTINY841 chip not all the pin’s. were all the way connected thank’s