Problem with listening on UDP port

Hi, I’m trying learn how to use Node-Red and am attempting to send it a UDP packet from my PC and have it display the payload in the debug window with this simple flow (also injecting “blah” as a test):

[{“id”:“cfaafe56.9e7118”,“type”:“inject”,“z”:“232afa27.9b8b12”,“name”:"",“topic”:"",“payload”:“blah”,“payloadType”:“str”,“repeat”:"",“crontab”:"",“once”:false,“x”:256,“y”:138.22999572753906,“wires”:[[“796d20e2.36e8a”]]},{“id”:“796d20e2.36e8a”,“type”:“debug”,“z”:“232afa27.9b8b12”,“name”:"",“active”:true,“console”:“false”,“complete”:“false”,“x”:454,“y”:113.47000122070312,“wires”:[]},{“id”:“5490f5e7.16ffbc”,“type”:“udp in”,“z”:“232afa27.9b8b12”,“name”:"",“iface”:"",“port”:“1234”,“ipv”:“udp4”,“multicast”:“false”,“group”:"",“datatype”:“buffer”,“x”:248,“y”:93.22999572753906,“wires”:[[“796d20e2.36e8a”]]}]

I’ve tried everything I can think of but no data arrives at the UDP input.
Is there something else I need to do to allow a listening port to open?
I have tried another flow where I am transmitting a UDP packet to my PC and that works.

I have created a udp send using its own ip address in the same flow and it works sending udp to itself. If I do the same sending flow on my other emonPi, nothing is received, so there must be something blocking external incoming udp.
Is there any deeper debugging/logging I can do to figure out why this doesn’t work?

Have you opened the port in UFW (UncomplicatedFireWall) ?
eg

[email protected]:~ $ sudo ufw status
Status: active

To                         Action      From
--                         ------      ----
SSH                        ALLOW       Anywhere
WWW                        ALLOW       Anywhere
RDP                        ALLOW       Anywhere
SSL                        ALLOW       Anywhere
224.0.0.1                  DENY        Anywhere
50022                      ALLOW       Anywhere
SSH (v6)                   ALLOW       Anywhere (v6)
WWW (v6)                   ALLOW       Anywhere (v6)
RDP (v6)                   ALLOW       Anywhere (v6)
SSL (v6)                   ALLOW       Anywhere (v6)
50022                      ALLOW       Anywhere (v6)

Thanks @pb66 that was exactly what I needed to know. :+1:
On this occasion, google was not my friend.
All working now:

[email protected](ro):~$ rpi-rw
Filesystem is unlocked - Write access
type ’ rpi-ro ’ to lock
[email protected](rw):~$ sudo ufw allow 1234
Rule added
Rule added (v6)
[email protected](rw):~$ rpi-ro
Filesystem is locked - Read Only access
type ’ rpi-rw ’ to unlock